Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Client does not support https. That is all I am getting. I even tried the basic HTML link.

share|improve this question
add comment

migrated from stackoverflow.com May 6 '11 at 0:34

This question came from our site for professional and enthusiast programmers.

2 Answers

up vote 5 down vote accepted

Works for me:

http://mail.google.com/mail/?ui=html

or

http://mail.google.com/a/YOURDOMAIN/?ui=html

Ctrl-X E to edit in external editor.


Are you using a version prior to 2.8.7?

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=488219


EDIT: I downloaded the oldest of the 2.8.8 lynx sources. After trying out different options it was configured without ssl support by default and I reproduced the error. Configuring & building lynx in the following way fixed the problem:

# download the lynx source
./configure --with-ssl --enable-gnutls-compat
make
./lynx https://mail.google.com

Remember to use --prefix=<prefix of directory containing lynx.cfg> and --with-pkg-config=<directory prefix of binaries> with configure. I use Arch Linux so these were "/" and "/usr" respectively, For debian based distros you shouldn't need these. I just thought it worth mentioning.

share|improve this answer
    
still doesnt work. I am using 2.8.8 –  yayu May 5 '11 at 22:30
    
What distro, OS and release (if not rolling release) are you using? –  andreasw May 5 '11 at 23:02
    
Nice answer, @andreasw. +1 for you. –  user3463 May 6 '11 at 2:46
    
Mac OS X. I will try to implement this and get back. –  yayu May 6 '11 at 4:04
    
You may just want to build & install with Fink or MacPorts. The lynx packages from both systems include support for https. Also, that way you have it managed by a package manager. –  andreasw May 6 '11 at 4:40
add comment

I used MacPorts to install lynx

port info lynx  
lynx @2.8.7rel.1, Revision 1 (www)  
Variants: gnutls, [+]ssl, universal  

to install:

sudo port install lynx +ssl

Lynx will access my gmail!
I changed the following option so not to be asked each time:

SSL Prompting

This allows you to tell how to handle errors detected in SSL connections prompt normally to prompt for each cookie, force yes-response to reply "yes" to each prompt, force no-response to reply "no" to each prompt.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.