Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've tried using iBus as a Japanese input method. I installed it from the repositories, as well as ibus-anthy, and it's sometimes functional, but not on Firefox or Thunderbird, which is where I need it most...

I tried removing it and installing SCIM, but I can't get it to work at all. I might just be botching up the configuration, though.

share|improve this question
up vote 2 down vote accepted

I managed to fix it. In the end, I used IBus. Before, I was trying to run ibus-setup which would start the IBus daemon, but it appears that the daemon wouldn't have the correct permissions to be able to set up triggers everywhere, or something to that effect.

Under KDE 4.6, I went to System Settings -> Locale -> System Languages -> System Default, and selected my default language (English), and set the keyboard input method to ibus. Then, a quick restart ran the daemon on startup and it worked fine.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .