Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running the JBoss webserver on my ubuntu (10.10 64bit) machine and I'd like to access it from another machine.

If I open localhost:8080 in the browser on my local machine it works. However, from the remote machine I can ping my ip address, but I can't access port 8080. I also can't seem to see port 8080 by running netstat -pan.

How can I open up port 8080 to the world?

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

Are you sure your server isn't configured to listen only on localhost (lo) interface? Look for its configuration and have it listen on all interfaces.

The default startup script for Jboss has the following line to specify which IP address Jboss should bind itself to

JBOSS_BIND_ADDR=${JBOSS_HOST:+"-b $JBOSS_HOST"}

You can either edit this line or if you are running [u|l]inux system, you can add the following line above this line

JBOSS_HOST=hostname

share|improve this answer
    
Yes! Thank you very much. Looks like you need to run jboss with the command 'bin/run.sh -b 0.0.0.0 -c web' –  Rehno Lindeque May 6 '11 at 9:10
add comment

Are you sure you haven't enabled the Firewall?

sudo ufw disable

This might be a security risk you can choose to ignore. If you want to configure your firewall later, check this documentation of ufw.

share|improve this answer
    
I ran 'sudo ufw status' earlier and it gave me 'Status: inactive', thanks... –  Rehno Lindeque May 6 '11 at 9:01
    
Now that's kind of strange. Sorry that didn't work out. –  slhck May 6 '11 at 9:03
    
No worries, could have been the firewall quite easily, thanks for the help! –  Rehno Lindeque May 6 '11 at 20:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.