Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The other minute I updated Ubuntu from 10.10 to 11.04. I configured the system to always log in user A.

Now when I start it, the computer boots and loads the Desktop of user A, but there you can do nothing but moving the mouse. The Unity panel is empty and the task bar is not clickable, as well as any items on the desktop.

Switching to a terminal with Ctrl-Alt-F2 I found out, that the Zeitgeist daemon hangs and became a zombie, which I think might be the reason. However, if I kill the daemon, the desktop becomes fully black.

I moved old config files from /home/userA away (.compiz, .config, .local, .gconf*, .gnome2*), but that had no effect.

Has anyone an idea, what I could try? My only idea left is to re-setup the whole system (not my favourite).

Update: It's something stranger. After aptitude remove unity zeitgeist-core the computer loads Gnome, but with a similar issue: Only the Desktop background and the mouse are visible. No panels, no desktop icons, no nothing.

Journey continues: I disabled autologin via terminal. The login screen appears on startup as usual, and I can select any normal user. But for each one the result is the same: No interaction with desktop possible.

Next puzzle piece: This thread suggests the nVidia driver being the culprit. The suggested solution ("Load clasic, no effects") works for me. Issue solved, but I'm not satisfied.

share|improve this question
1  
This is just FYI: bugs.launchpad.net/zeitgeist-datahub/+bug/772265 3rd comment down. You may want to add a comment/open a new bug since they think the zombie issue is sorted. –  Tog May 6 '11 at 10:15
    
Oh, what irony! I'm looking at an Ubuntu ad in the right column right now :-) –  Boldewyn May 6 '11 at 14:22
add comment

4 Answers

You can try to reinstall some packages without installing the whole system with the following:

apt-get --reinstall

You could also try removing the whole home directory of the user and creating a new one.

share|improve this answer
    
Removing the whole home dir (+ creating new empty one) didn't help. Reinstalling Zeitgeist didn't help either, sorry. –  Boldewyn May 6 '11 at 13:56
add comment
up vote 1 down vote accepted

As I said, it was the Nouveau driver, and the fix was to not use Unity in the latest-and-greatest version but its 2D stepsister, http://ubuntuforums.org/showthread.php?t=1728379.

share|improve this answer
add comment

Check out this post: https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/684083

@anujahooja

Please use the approved proprietary driver we provide via the "Additional Drivers" application from within the system settings. You can also launch this application from the command line by typing:

sudo jockey-gtk

We cannot be responsible for effectively debug systems using drivers we have not provided, sorry.

share|improve this answer
    
Thanks. However, I used the approved proprietary driver, and 11.04 setup changed it against Nouveau under the hood. Great job! –  Boldewyn May 10 '11 at 11:51
add comment

I had the same problem using synergy, configured as described on https://help.ubuntu.com/community/SynergyHowto

It starts synergy as root on gdm. In 10.10 it was killed by root and started again as a user. 11.04 seems to have changed behaviour so the login scripts are ran as user instead of root as soon as the user logged in. The consequence is that a normal user is trying to kill the synergyc started by root and hangs while waiting for it.

Perhaps something similar is happening to you?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.