Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Hi I have Visual Studio 2010 ultimate. Recently when i started it, it came up with an error message saying

Microsoft.VisualStudio.Labs.SolutionNavigatroPacage, SolutionNavigator, Version 10.0.0 package did not load correctly.

I continued and the VS opened fine, i opened my project and tried to build. It shows a message saying,

No valid exports were found that match the constraint '((exportDefinition.ContractName == "Mef_MSDN_Article.ILogger") AndAlso (exportDefini-tion.Metadata.ContainsKey("ExportTypeIdentity") AndAlso "Mef_MSDN_Article.ILogger".Equals(exportDefinition.Metadata.get_Item("ExportTypeIdentity"))))', invalid exports may have been rejected.

I tried repairing visual studio which did not help any solutions?

share|improve this question
    
Sounds like a possible HKEY conflict. Is this the first Visual Studio you've installed on that system? – Blomkvist May 6 '11 at 11:53
    
Did it ever work? If so, did you try using Windows Restore to go back to before you had this problem? – Ƭᴇcʜιᴇ007 May 6 '11 at 16:08
    
i can't herform system restore.... we reinstalled vs but no help. i ve vs 2008 installed and it works fine... – Amit May 11 '11 at 7:49

You must log in to answer this question.

Browse other questions tagged .