Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I noticed this first on a Business Hub. If you download something big (CD or DVD image for example) and the download is using the full bandwidth available to you, DNS lookups stop working on the hub (whether its through a browser or a tool such as nslookup). You can still ping WAN IPs and do an nslookup if you specify another server, and internet sessions that don't require DNS (where you know the IP) aren't affected - they keep working fine, if a little slowly ~(which is to be expected).

It started happening on a several-year-old Business Hub about a year ago, and I thought it might just be the hub. In the last month or so though I've started using another Business hub of the same model (BT2700HGV), and it has the same issue. I've also moved to BT at home recently, and now have a Home Hub 3, which also does this.

Has anyone else experienced this with BT or other hardware? I've never experienced it with other modem/routers, including really old ones that can barely stay up for 24 hours without crashing.

share|improve this question
add comment

1 Answer

Yes, I have seen this happen with BT Home Hubs, when under load. Have you tried using another DNS server, setting it in the computers' network settings, and not using the router's DNS relay? I cannot remember if this would help, but it is worth a shot.

(I'm assuming that you are not using a domain and local DNS server on your network and that the network adaptors are using the default names, which you can find on the Networking tab of Task Manager)

To set Google's DNS servers, open an elevated CMD Prompt and paste these lines in, one at a time:

netsh int ipv4 add dnsservers "Local Area Connection" 8.8.8.8 index=1
netsh int ipv4 add dnsservers "Local Area Connection" 8.8.4.4 index=2

For wifi, try:

netsh int ipv4 add dnsservers "Wireless Network Connection" 8.8.8.8 index=1
netsh int ipv4 add dnsservers "Wireless Network Connection" 8.8.4.4 index=2

For the GUI method, try this. Step 6 is the relevant part.

share|improve this answer
    
The above instructions are for Windows Vista and later. They need to be slightly changed for Windows XP and earlier. Other OSs will have a completely different procedure. –  paradroid May 6 '11 at 11:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.