Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Because I need a bug fix which is not available in Ubuntu's repository version of subversion, I am installing it from source.

On running ./configure, I get an error:

configure: WARNING: APR not found
The Apache Portable Runtime (APR) library cannot be found.
Please install APR on this system and supply the appropriate
--with-apr option to 'configure'

or

get it with SVN and put it in a subdirectory of this source:

   svn co \
    http://svn.apache.org/repos/asf/apr/apr/branches/1.2.x \
    apr

Run that right here in the top level of the Subversion tree.
Afterwards, run apr/buildconf in that subdirectory and
then run configure again here.

Whichever of the above you do, you probably need to do
something similar for apr-util, either providing both
--with-apr and --with-apr-util to 'configure', or
getting both from SVN with:

   svn co \
    http://svn.apache.org/repos/asf/apr/apr-util/branches/1.2.x \
    apr-util

configure: error: no suitable apr found

Notes:

1) I have already installed libapr1

2) I am not able to install svn client, to follow the instructions in the error message (apt-get install svn - no package found - I have main, universe, restricted, multiverse in sources.list)

share|improve this question
add comment

1 Answer

up vote 8 down vote accepted

To compile a program depending on a library you generally need the developer package. In your situation you need to do: apt-get install libapr1-dev. And don't forget to repeat it with apt-get install libaprutil1-dev.

share|improve this answer
    
Thanks. This worked. Getting another error now. By any chance do you know the package for this? (Searched on google but didnt find apt-get package) ............................... configure: WARNING: APRUTIL not found The Apache Portable Runtime Utility (APRUTIL) library cannot be found. Either install APRUTIL on this system and supply the appropriate –  tanon May 7 '11 at 14:37
1  
same thing install the package called: libaprutil1-dev –  slubman May 7 '11 at 14:43
    
thanks! worked like a charm –  tanon May 7 '11 at 16:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.