Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am unable to start any of my VMs interactively. They work when run headless however (--type vrdp)

If I try to run normally I get:

$ VBoxManage startvm Kubuntu
Waiting for the VM to power on...
VBoxManage: error: The virtual machine 'Kubuntu' has terminated unexpectedly during startup because of signal 6
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component Machine, interface IMachine, callee 

My host machine is an Intel iMac running 10.6.7, and I'm using VirtualBox 4.0.6 with the Oracle extensions installed.

Any ideas?

Further info: The virtual machines start up just fine interactively if I use sudo. That seems to imply there is some sort of bad permission or locked file or something somewhere, but I have already checked all the files in Library/VirtualBox.

share|improve this question

migrated from May 7 '11 at 12:41

This question came from our site for system and network administrators.

What were the hosts? Were they all Kubuntu? The first error line is indicating that the host has shut down (Kubuntu called abort, thus sending SIGABRT to VBox). This makes it look like the host is the problem, but you implied that there are multiple failing hosts. Did you fix it? If so, how? – Synetech Nov 26 '12 at 3:25

I had this exact problem with all my VMs running on Mac OS X 10.7.5 host. A reboot solved the problem, since none of the .vbox files seemed to have any problems.

share|improve this answer
Rebooted what, the host or the guest? – Synetech Nov 25 '12 at 22:07
The host. No VMs were able to run, so that was the only thing that could be rebooted :) – Kekoa Nov 26 '12 at 2:56
Jeff indicated that he can boot and reboot his guests. If they are all being affected then rebooting the host may indeed help. – Synetech Nov 26 '12 at 3:21
Rebooting the host seems to solve it effectively – knokio Jan 19 at 18:54
sama problem on el-capitan 10.11, works also – ismailsunni May 10 at 10:07

Firstly, backup your VM (including the disk image and everything that goes with it).

Then, go into the folder in which your VM is held. In there, you should see a file called "VirtualBox.xml", and HOPEFULLY, a file called "VirtualBox.xml-prev". Rename the "VirtualBox.xml" file to "VirtualBox.xml.old", and then rename "VirtualBox.xml-prev" to "VirtualBox.xml". Try starting your VM again - the error should be gone.

If you don;'t have a VirtualBox.xml-prev file, then try creating a new VM, and use your old disk image. That process will re-create the VirtualBox.xml file for you.

Remember to back up!

share|improve this answer
If you're referring to a single VM, then this is not the problem. I've even gone so far as to clone the disk image and create a brand new machine. This is something more systemic, NONE of my half-dozen VMs will start normally, but they'll all start headless. If you're referring to the global config file for all VMs, I haven't tried messing with that yet so I'll take a look at it. – Eggplant Jeff May 9 '11 at 14:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .