Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows 7 Professional PC on a home network that I would like to share media from. However none of my other home computers will recognize the PC as a media device, though they do recognize each other. The PC in question is visible to the other PCs too, just not its media library. I'm dumbfounded as I'm confident that I've shared what I could.

The other PCs are Windows Vista Ultimate and Windows 7 Home Premium.

Does this have anything to do with IIS, since this is the only networking feature that I identify to be different from the other two systems? The specification for the PC is as follows:

  • Windows 7 Professional 32-bit
  • Windows Media Player 12
  • Media Streaming - enabled
  • File, printer, music and video sharing - enabled
  • Network discovery - enabled
  • Media sharing is set to allow all

I've tried:

  • Allowing all access in firewall
  • Setting the user to Local System and restarting the Windows Media Sharing service
  • Resetting firewall defaults, and then re-enabling media streaming
  • Restarting the PC
  • Disabling and enabling UPnP in the router settings
  • Changing homegroup to make sure they were on the same one (MSHOME)
share|improve this question
1  
@Gareth - how can I one up you for correcting my post? –  Jakob May 12 '11 at 14:48
    
no need :) –  8088 May 13 '11 at 4:00
    
Not that it is related here, but as mentioned in superuser.com/questions/433547/… I universally recommend disabling UPNP on routers. I'm not sure how windows sharing works anymore, but the setting on the router shouldn't matter, and at worst presents a security hazard. –  killermist Jun 12 '12 at 18:48
add comment

1 Answer

The stuff you want to share has to be in your media library in order to share it. If you just make a network share does it recognise the pc and the shared folder?

share|improve this answer
    
it recognizes the pc, but not any media libraries. It doesn't recognize the pc as a "media device" –  Jakob May 12 '11 at 14:44
    
Have you tried with the firewall completely off? –  xciter May 18 '11 at 8:35
    
Yes firewall completely off didn't change anything unfortunately –  Jakob Jun 1 '11 at 14:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.