Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a 2TB Western Digital external USB drive that I formatted to FAT32. It takes a minute and 25 seconds for Windows to recognize it when I plug it in. I've tried multiple computers. It only takes around 14 seconds on Linux. It seems anything Microsoft has trouble with it. XBOX 360 behaves the same way, while Playstation 3 works fine. Maybe I should make two 1TB partitions? I'm not entirely sure, but I think the problem wasn't there before I formatted to FAT32.

share|improve this question
Which version of Windows are you using? I had some issues using external USB hard disks with Windows Vista, and those issues were solved after I upgraded to Windows 7. – Mantis Jul 6 '11 at 21:04

According to my experience, Operating system from Microsoft is one of the reason. It means, windows takes time to load FAT32 partition. Rather than this LINUX & OSX has powerful utilities to access such external disk. So, I just recommend you to use your external HardDisk with NTFS partitions.

share|improve this answer

I wouldn't use FAT on partition that large. Linux can read and write NTFS fine nowadays, if you use ntfs3g driver, and there are applications on accessing EXT3 partitions in Windows.

So I would use NTFS, or possibly EXT3. NTFS offers smoother ride if you need to access the disk from both Windows and Linux while EXT3 is harder to break due to journaling.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.