Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My drives and volumes all have their own dedicated icons, descriptive comments, folder backgrounds, and default labels.

Recently however, the icons and comments that should be visible in My Computer suddenly disappeared (the default labels and folder backgrounds are still shown).

I’ve checked, and the desktop.ini files are still present and correct, as are the HKLM\Software\Microsoft\Windows\CurrentVersion\Explorer\DriveIcons registry entries (there are no HKCU\Software\Classes\Applications\Explorer.exe\Drives entries).

I also tried using the rebuild-icons function of TweakUI to no avail.

Does anyone know what could be wrong? Is there a setting (such as a policy) that could be blocking or overriding it?

share|improve this question
add comment

1 Answer 1

It turns out that the custom icon/comment feature is the domain of the Shell Hardware Detection service which I had previously set to Manual since I do not use any Autoplay functions. Starting the service (and setting it to Automatic for subsequent sessions), brought them back.

share|improve this answer
    
(Woah; I can’t believe they’ve been missing for over a year! Well at least they’re back. Yay!) –  Synetech May 15 '12 at 6:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.