Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was trying to do something with dd command in Ubuntu's terminal. But I screwed up. I don't really remember what the command was.

But after I ran it, I restarted the PC and I read a message "No operating system found".

So as I wanted to install the new Ubuntu, 11.04, I just picked up a bootable pen drive with that OS and tried to install it. I wanted to completely clean the hard drive and make a fresh install. How ever when I try to do this, in the middle of the installation an error message pops up and it says that there was an error installing GRUB.

I don't have anything else in the hard drive, no particions and only one disc. What can I do?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Take a rescue CD like Knoppix and clean the disk with dd:

dd if=/dev/zero of=/dev/sda bs=1024000

Use /dev/hda for older systems. After this initialize the partition table with fdisk. After that try to install Ubuntu.

share|improve this answer
    
I am going to try that and tell the results in here. Thank you! –  petermlm May 8 '11 at 17:40
    
It worked without problems. Thank you very must! –  petermlm May 8 '11 at 18:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.