Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been trying to update my ~/.fonts.conf file but it just won't work.

I tried going "su" to move or "chmod" it but the same problem.

SELinux is set to permissive and I don't understand why it is not working.

see some outputs...

% sudo -i mv /home/marc/.fonts.conf /home/marc/Downloads/
% mv: cannot move `/home/marc/.fonts.conf' to `/home/marc/Downloads/.fonts.conf':Operation not permitted

I also tried being root "su -" and the same error!

trying just to edit on Nano or another editor. gives me "permission denied"

here are the permissions for the file checked by ls -la...

-rw-rw-r--. 1 marc marc 91 May  4 17:45 .fonts.conf

I use Fedora 15(beta)

Am I missing something? Please, any help is appreciated.

OBS: When installing fedora 15 I decided to keep my home partition and I remember a message saying that SElinux had troubles trying to fix permissions for my user and proposing me to check those settings myself but no link or something about where to them. :S

share|improve this question
Operation not permittedPermission denied – squircle May 9 '11 at 0:37
Does 'cp' work? – Adam Prax May 9 '11 at 19:35
yes it does but I want to overwrite it – marcjunior May 11 '11 at 0:01

If cp works then we know that you can write to the target directory, so when mv fails it must be because you can't remove (unlink in unix speak) the file from the source directory.

Now "Operation not permitted" is EPERM and according to the unlink(2) manual page there are two ways to get that when unlinking a file:

   EPERM (Linux only)
          The file system does not allow unlinking of files.

          The directory containing pathname has the sticky  bit  (S_ISVTX)
          set  and  the  process's effective UID is neither the UID of the
          file to be deleted nor that of the directory containing it,  and
          the  process  is  not  privileged  (Linux:  does  not  have  the
          CAP_FOWNER capability).

To be honest both of those seem unlikely, but you should certainly check the permissions on your home directory by doing:

    ls -ld /home/marc

If the sticky bit is set you will see a t character at the end of the mode string.

Incidentally the important thing to realise here is that when deleting a file on a unix system it is the permissions on the directory you are removing it from which matter, not the permissions on the file being removed.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.