Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Windows 7 Ultimate 64-bit on a Dell machine and when I install that hard drive in a HP Touchsmart laptop, Windows BSODs after the "Starting Windows" and "fireflies" logo. Same deal if I install the hard drive on HP, install Windows 7 and then try to use the hard drive on the DELL.

Is there anything specific I need to do to allow me to transfer the hard drive between Dell and HP?

share|improve this question

migrated from serverfault.com May 9 '11 at 12:14

This question came from our site for professional system and network administrators.

2 Answers 2

up vote 6 down vote accepted

Yes. The correct drivers.

You can't just swap drives from one manufacturer to another unless all the hardware matches. Even if you did, Windows may detect the changed hardware and require reactivation.

Install Windows on each system from a base install, if you have the proper licensing to do so. Otherwise what you're doing could be against your licensing agreement.

share|improve this answer
    
thanks for the response. I thought I could get windows to "repair" itself and get the right drivers installed to the new hardware. –  Rams May 9 '11 at 12:22
    
Rarely, when it manufacturer specific. Windows has a lot of drivers, but when you switch between two totally different machines it will usually crash. –  Bart Silverstrim May 9 '11 at 13:00

BSOD/crash/reboot at this stage of boot sequence is typically caused by "inaccessible boot device" error which is usually related to missing drivers to access the disk sub system. Often this happens if Windows was installed to an IDE disk (or SATA disk operated in IDE/compatibility) mode and later switching to a mainboard which supports native SATA (AHCI) mode.

There are three solutions for this problem: - Re-enable AHCI service - Configure drives to work in IDE mode - Re-install Windows

To re-enable AHCI it's required to enable the msahci service. If I remember correctly you need to set the start value at HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\msahci to the value of 0 (automatic start). You can do this from WindowsPE if your system is unbootable or by loading the SYSTEM hive located at from %SystemRoot%\system32\config\SYSTEM on any other machine (e.g. by attaching it to an USB-enclosure). However the best method is to do this BEFORE you move the HDD to another machine or before you replace the mainboard.

Alternatively you can try to enter the BIOS of your new machine and configure SATA drives to IDE or compatible/legacy/whatever mode (sorry, the concrete menu item looks different on almost any mainboard). Unfortunately many laptops do not offer such a menu item. If you managed to boot Windows in IDE compatibility mode you might apply the changes described above to re-enable msahci and then re-enable AHCI mode in BIOS. This would enable AHCI features like NCQ and gains you some HDD performance.

I think it's not necessary to explain the re-install option.

Remember that if you move the HDD to an entirely new machine Windows most likely needs to be re-activated (check system property panel). Also the first boot will likely take pretty long as all devices will be re-enumerated and installed. Watch the device manager for missing drivers.

share|improve this answer
    
Thanks for the suggestions. Will follow and get back if it worked. –  Rams May 17 '11 at 12:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.