Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I have two 3TB Hitachi 5k3000 Desktar drives that I want to use as data drives, not boot drives. When I was originally trying to install them I wanted to mirror them using my hardware raid but I couldn't get them recognized, my motherboard is pretty old (P5N32-SLI) but the BIOS and RAID firmware are as up to date as possible.

Whilst trying to get the drives recognized I found you need to initialize them to GPT to see past the 2.2TB barrier, I tried initializing one in Windows (7 x64) via a USB drive enclosure and even though it was set to GPT it never reported the correct size only 746GB.

Next, I tried initializing the other disk connected via the internal SATA ports on my motherboard and it actually reported the correct size (in MBR mode it reported 2.2TB and 746GB, when I switched to GPT it showed one continuous volume.) However, now I can't get my other one to reinitialize, I tried switching it back to MBR but that did not make a difference. I suspect Windows is caching something about this drive that I'm not seeing, but would greatly appreciate some guidance.

Edit: I don't want to use these with my USB enclosure, I want them internal. One drive does work as expected internally, just the one I originally tried to initialize via the enclosure won't re-initialize internally with the correct space.

share|improve this question

migrated from May 9 '11 at 13:46

This question came from our site for system and network administrators.

marked as duplicate by fixer1234, DavidPostill, nc4pk, BlueBerry - Vignesh4303, Deltik Jul 30 '15 at 6:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

To close voters: this post is older than the suggested duplicate. Perhaps the newer post should be closed instead. @fixer1234 – Excellll Jul 29 '15 at 17:40
@Excellll: I saw that; thought the newer one had better answers. But I'm happy to go with the community decision if age should take precedence. – fixer1234 Jul 29 '15 at 19:28
up vote 7 down vote accepted

Typical USB drive enclosures have historically only supported up to 1.5 TB of capacity. I have a feeling this has something to do with the 32bit nature of the enclosure, but I could be totally off on that one. Make sure the enclosure's specifications state that it supports drives larger than 1.5 or 2 TB.

Thus far, I have only seen USB 3 (SuperSpeed) enclosures supporting anything at or larger than 3 TB.

Edit (from comments): If you're concerned that Windows might be caching something about the drive then you can try to fix it on another machine, or access it using a live cd like GParted.

share|improve this answer
Yea the USB enclosure pooched the drive I tried to initialize in it, the question is more about how to unpooch it when plugged into my internal SATA ports. – JaredMcAteer May 9 '11 at 16:15
Ah, I understand now. The only suggestion I can come up with at this point is, if you're concerned that Windows might be caching something about the drive then you can try to fix it on another machine, or access it using a live cd like gparted. – raffi May 9 '11 at 16:46
I will try GParted Live when I get home. Thanks. – JaredMcAteer May 9 '11 at 19:48
GParted worked perfectly, I was able to delete the boot sector that the USB created and re-initialize the disk, Windows now detects it properly. – JaredMcAteer May 9 '11 at 23:14
Awesome! Glad to hear it, and thanks for following up. I'll keep this in mind next time I hear of a similar issue. – raffi May 10 '11 at 19:34

Try zeroing out the first 1k (Boot sector) of the drive, Use Hitachi's "Drive Fitness Test" boot disc to do this.

share|improve this answer
Thanks, since it's a boot disk I'm going to have to try this when I get home. Edit: Hmmm I just looked at the page and it doesn't support 3tb+ drives – JaredMcAteer May 9 '11 at 14:37
While this tool wasn't appropriate for my situation it probably would have worked on a smaller drive, I can't give you the answer for this question but I did give you an upvote. – JaredMcAteer May 9 '11 at 23:14
@OriginalSyn, Glad you solved the problem. – Moab May 10 '11 at 14:56
@OriginalSyn, its only one tool on the boot disk that does not support 3tb drives, "Currently the "Feature Tool" does not support 3TB and greater internal drives." – Moab May 10 '11 at 15:02
Ah I didn't parse that text correctly, thanks for the clarification. – JaredMcAteer May 10 '11 at 17:32

This problem is resolved in my 10 years old HP desktop (4 cores), with drive: 3TB Western Digital Green.

In a nutshell you need 2 things to do:

  • to install the Intel RAID driver (free).
  • to use a good tool for extending the partition to the maximum size, like AOMEI Partition Assistant (freeware).


PS1: After all is setup property, you can uninstall both tools mentioned above.

PS2: If you have any conflict between the new 2TB or 3TB disk and the old DVD-ROM then disconnect the DVD, and get an external one (my case).

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.