Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I upgraded to Firefox 4 and now favicons don't show in my tabs.

How to I get them to show? They exist in the bookmarks.

share|improve this question
    
Just for understanding: Do you see the favicons in your bookmarks but not in the tab? Or do you don´t see any favicons at all? –  Diskilla May 9 '11 at 15:48
    
on my XP box, after the upgrade I don't see them either place. On W7 box they are fine. –  gr3yrider May 9 '11 at 16:12
    
I have so many tabs open all I can see are the favicons. I can imagine how annoying it would be to lose those! What "skin" are you using? –  Mr.Wizard May 10 '11 at 17:25

4 Answers 4

I could be caused either by Greasemonkey or a favicon picker extension.

When I disabled them, the problem disappeared. It worked afterwards also when I re-enabled them.

share|improve this answer
    
I had a same problem.Thanks @Ludoja, after uninstalling Favicon Picker extension everything goes back to normal :) –  NT. Sep 18 '11 at 11:04

To those who have made suggestions to resolve my problem: I solved my problem, mostly, by brute force. I removed FF4 from my XP machine. I had to use Revo to remove all traces including all bookmarks, etc.. Then I reinstalled FF4. After I reinstalled I sync'd the new install with what was on my W7 machine. This refreshed my bookmarks but not the favicons. I then used the Check Places add-on to get the favicons on my bookmarks, when a favicon existed on the site. Victory!

There are obviously sites that do not provide favicons but I can create favicons for those. I have at least one site the does not provide a favicon that I have not figured out. It is a financial institution and the favicon I create shows in the bookmark and will show momentarily in the tab when I visit the site but it then vanishes and I cannot get it to stay in the tab, weird.

Thanks to everyone for your suggestions.

share|improve this answer
    
You can accept tour own answer. –  Luc M Sep 16 '11 at 16:57

Given how deep the changes go in Firefox 4, you may want to just create a fresh profile and copy over your stuff.

For me, the upgrade brought stuff like the address bar not changing when I changed tabs and making a fresh profile only took me maybe an hour as opposed to a day or more.

Here's a summary of the ways I found to make it as painless as possible:

  • Use the Add-on Collector extension to sync your installed addons via a private collection.
  • If you use Greasemonkey, with Firefox not running...
    • Copy the gm_scripts folder from the old profile to the new one.
    • Open prefs.js in the old and new profiles and copy the block of greasemonkey.scriptvals. lines over.
  • If you use Stylish, with Firefox not running, copy stylish.sqlite from the old profile to the new one.
  • If you use NoScript or SiteLauncher, use their Import/Export buttons to copy your settings over.
  • Export all bookmarks with "Import and Backup" button in the Bookmarks editor window.
    • This also covered search engines for me since putting a %s placeholder in a bookmark's URL and setting a keyword gives a more Polished Omnibar-style experience than setting a keyword on search engines installed via the search box.

...and then, with the export/import process having done some ad-hoc sanitization on your bookmarks, sign up for Firefox Sync so your bookmarks, saved passwords, history, open tabs, and a safe subset of your preferences won't have to be manually copied over the next time. (I could be wrong, but I think AdBlock Plus also supports Sync for its settings. NoScript can be synced via Bookmarks Sync.)

share|improve this answer

The most common (and normal) scenario that assumes nothing else has fundamentally gone wrong with your Firefox installation is to simply clear your cache and visit the site. It should immediately load up the favicon at that point.

If that does not remedy things, you can try to make sure that in your about:config settings, the "browser.chrome.favicons" preference is set to "true".

share|improve this answer
    
I've cleared the cache. I've verified the about:config settings and "browser.chrome.favicons" preference is set to "true". Guess I don't understand what difference that makes for FF though. Thanks but I'm still stumped. –  gr3yrider May 9 '11 at 18:51
    
If the usage of the term "Chrome" in there caused confusion, then hopefully this link will clarify that. It's not meant to be confused with Google's Chrome. Otherwise, it's kind of weird that it's not working for you. If I think of something else I'll mention it. –  raffi May 9 '11 at 19:33
    
Thx xtremesniper, that helps but the terminology gets confusing with the use of the word chrome. I'm frustrated with favicons but I find them necessary, especially when using app tabs. –  gr3yrider May 9 '11 at 19:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.