Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Windows 7 Home Premium asks me to shut down and install updates on every shut down.

When it boots up, it says "Configuring your updates... 0%" and after about five minutes it changes to "Failed update, rolling back."

I can't find anywhere to cancel these updates so that they don't run.

Any ideas how to fix this?

share|improve this question
1  
You might look in the System Event log for an error message. Its could give us a clue as to what's happening –  uSlackr May 9 '11 at 18:14
add comment

2 Answers

up vote 5 down vote accepted

Turn off updates:

Click Start, Choose Run.

In the Run box, type services.msc.

Click OK.

Right-click the Automatic Updates service.

Click Stop.

Then rename the “SoftwareDistribution” folder:

Click Start, click Run, type %systemroot%, and then click OK.
Right-click the SoftwareDistribution folder, and then click Rename.
Type SoftwareDistribution.old, and then press ENTER to rename this folder.
Create a new folder called "SoftwareDistribution"
Click Start. Choose Run.
In the Run box, type services.msc.
Click OK.
Right-click the Automatic Updates service.
Click Start.
share|improve this answer
    
Great answer thanks. –  Alan Whitelaw May 10 '11 at 17:24
add comment

Run the Microsoft Fix it 50202 tool from Microsoft's website.

It is compatible with Windows 7.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.