Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is something that has annoyed me since I changed to Windows 7.

I haven't done double clicking for a long time now since Windows introduced single click activation (Folder Options > Click items as follows > Single click to open an item).

The problem is, when I press CTRL and hover over the items, they get selected/deselected automatically with every small amount of mouse movement I make.

What I want is to select/deselect the items only when I enter/exit them. So to deselect an item I'm hovering, I have to move the mouse off of it, and then back on.

I'm using the official IntelliMouse Explorer drivers.


(edit)

Here's another related annoyance: when you are hovering over something and move the mouse onto another item (while holding CTRL) the new item may or may not get selected. If you continue moving the mouse it gets selected/deselected as you move.


(more edit)

I have found that the parameter HKCU\Control Panel\Mouse\MouseHoverHeight / MouseHoverWidth have some influence here. If it's set to 2, the item select/deselect really quickly as you move the mouse. When set to larger numbers, its slower. But setting to 20 or 200 doesn't seem to make much difference.

share|improve this question
    
I can't seem to replicate this. Maybe it is worth testing without the intellimouse drivers? Are they definitely Windows 7 compatible? It might also be worth testing that your control key is working correctly - open the on-screen keyboard (Start->Run...->OSK) and check it does not flicker when the physical key is pressed. Or just try the other control key. –  James Jun 23 '11 at 9:32
    
Tried with a different mouse driver and same. Control key is fine. –  bortao Jun 27 '11 at 14:47
    
Did you upgrade an existing installation to Windows 7 or was it a fresh install? Do you have any unusual utilities installed that might affect mouse behaviour and have you had any other problems at all? It could be worth resetting your Windows theme (right-click desktop -> Personalize) as they can get corrupt and cause all sorts of strange issues. It might also be worth borrowing another mouse to see what happens in case something has gone wrong with the drivers. If the other mouse works, then you could try uninstalling and reinstalling the Intellimouse through the Device Manager. –  James Jun 27 '11 at 15:37
    
i have the same issue on both desktop+microsoft mouse or notebook+trakpad. it's a windows 7 thing that they changed from xp. –  bortao Jun 27 '11 at 19:02
    
I think I see the issue you are talking about. Strangely it does not seem to happen on the desktop though. –  James Jun 28 '11 at 8:48
show 1 more comment

1 Answer

There are several mouse registry settings from HKEY_CURRENT_USER\Control Panel\Mouse that might help you here :

MouseHoverTime : REG_SZ : hover time in milliseconds : 400 default
MouseHoverWidth : REG_SZ : hover width in pixels * 2 : 4 default (2 pixels)
MouseHoverHeight : REG_SZ : hover height in pixels * 2 : 4 default (2 pixels)

Width and height define the size of the hover rectangle, or in other words the number of pixels that the mouse can move and still be considered as hovering in-place. The hover-time specifies how long the mouse pointer has to stay in the hover rectangle before a mouse hover message is generated.

I have managed to duplicate some of your problems, and it seems to me that the "Single click to open an item" mode was really badly done by Microsoft, to select an item by just hovering over it. However, the behavior still looks consistent to me.

If you have changed mouse parameters, this might have had the effect of throwing off the mouse behavior.

My own preference is to counsel you to return all mouse parameters to the default and to turn off "Single click to open an item".

I also do not like double-clicking, but my solution was to program the wheel-click of my mouse as a double-click, this way achieving double-click via a single-click without monkeying with the mouse parameters. Microsoft software does not always work reliably with non-default parameters.

share|improve this answer
    
I already fiddled with those a lot. My Hover time is small, and width/height as explained on question. –  bortao Jun 26 '11 at 15:55
    
Try to use X-Mouse Button Control instead of IntelliMouse, like I did. The latest versions of IntelliMouse are just horrible. You could also uncheck Control Panel -> Ease of Access -> Make the mouse easier to use -> Activate a window by hovering over it with the mouse. –  harrymc Jun 26 '11 at 17:53
    
Uninstalled IntelliMouse, installed xmouse, turned off windows xmouse, Changed MouseHover* values, no change in behaviour. –  bortao Jun 27 '11 at 14:47
    
Try also this article. This thread says you need to search for UserPreferencesMask all over the registry and change as in the article. –  harrymc Jun 27 '11 at 19:12
    
@harrymc thanks but they are taking about raising the hovered window or not. (which by the way i changed because i like selecting the window xmouse style and not raising it, but this dont affect the selection behaviour) –  bortao Jun 28 '11 at 21:47
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.