Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've recently had some "Removable Disk" listings mysteriously appear along with my other drives. Clicking on one of them results in a dialog box:

Please insert a disk into Removable Disk (G:). "Properties" has no usable data.

How do I delete these "Removable Disk" listings?

Computer
Local Disk (C:)
Data2 (D:)
DVR (E:)
BD-ROM Drive (F:) DVD
Removable Disk (G:)
Removable Disk (H:)
Removable Disk (I:)
Removable Disk (J:)
Maxtor .5GB Set 2 LR Sec (K:)
LR3 Set3 Pri Seagate2TB (L:)
Grn Mxtr .5GB Bkup of Mxtr .5GB (M:)
Maxtor .5GB Set 2 LR Primary (N:)
Removable Disk (O:)
share|improve this question

3 Answers 3

If some of those drives are for things like camera memory card readers, then this is typically how they work.

To hide empty drive letters from the list, use the following menu options in Windows Explorer:

  1. "Tools" menu
  2. "Folder options" item
  3. "View" tab
  4. Enable the "Hide empty drives in the Computer folder" checkbox
  5. "OK" button

enter image description here

share|improve this answer

These sound like they may be from a media/memory card reader. You can set to hide empty drives to remove/hide them until you insert a memory card. Use the link: http://www.sevenforums.com/tutorials/6969-drives-hide-show-empty-drives-computer-folder.html to learn how.

Hope this helps,

share|improve this answer
    
Welcome to Super User! It would be nice to include the essential parts of the answer here, and provide the link only for future reference. –  slhck Aug 18 '11 at 9:57

There are two settings that control whether you can see the empty drives.

  1. 'Hide empty drives in the Computer folder'
  2. 'Hidden files and folders'.

If Show hidden files, folders, and drives is selected (the default is Don't show) then you will still see the hidden removable drives even if Hide empty drives in the Computer folder is ticked.

To hide the drives completely you need to:

  1. Click the Start button.
  2. Type Folder Options and press Enter.
  3. Select the View tab.
  4. Select Don't show hidden files, folders, or drives.
  5. Tick Hide empty drives in the Computer folder.
  6. Click OK.

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.