Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Here is my scenario:

I am using a Lenovo W510 Laptop with the i7 chip. It has 8 cores and 16GB RAM.

This laptop is running a Windows 7 64-bit base image with VMWare Workstation 7.1.4. I have already enabled the VT options in the BIOS and have checked them numerous times regarding this issue.

I launched VMWare Workstation and created a new virtual machine, walking through it's wizard. I pointed the machine to create off of the VMware-VMvisor-Installer-4.1.0-260247.x86_64.iso file from VMWare's download site. It installs ESXi just fine and I can connect to the the server via a web browser using it's ip address.

I then downloaded and installed the vSphere Infrastructure Client from the server and logged in to the server using that. I went in to the configuration tab and entered in my license key to remove the 60 day license message.

I then select File -> Deploy OVF. I pointed to an .OVA file that I have successfully deployed to an actual ESX server in my environment (following the same procedures as noted here). The OVF deployed successfully. I then powered it on and when GRUB was loading it said:

This kernel requires an x86_64 cpu but only detected an i686 cpu.

As an aside, I decided to ditch running ESXi in a VMWare image and installed the same version of ESXi natively on to the W510 laptop and the OVA file deployed and starts up just fine. So I'm confused and convinced there may be some setting in VMWare Workstation that I need to tweak, just not sure where. Any ideas?

share|improve this question
    
Update: I have attempted to mess around with toggling the CPU "virtualization engine" preferred mode drop down options on both the ESXi VMWare image as well as the OVF. I continue to have the same result. –  pian0man May 10 '11 at 18:46
    
I also tested this exact same scenario out on the desktop platform of this machine (ThinkCentre M90) with the same results. –  pian0man May 10 '11 at 18:46
    
I also tried toggling "Vmware kernel paravirtualization" as well as the disable acceleration options with the same result. In fact the paravirtualization setting ON gave me a 64-bit support error message. –  pian0man May 10 '11 at 18:51
    
It seems to be that VMWare Workstation is somehow telling itself that I have i686 vs. x86_64. –  pian0man May 10 '11 at 18:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.