Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a wubi install that is running great. Some of the setup though is pretty time intensive, and I didn't realize that WUBI was only meant for testing - I thought it would be equally as good as the regular installation :( So, I'd like to transfer my entire installation and move it to a new partition - with new swap partition and all.

Is there an easy way to do that? I tried looking at lvpm (or lpvm.. i forget), but Ubuntu 11.04 complains that it is low quality software. Is it safe?

Should I just install a fresh copy of 11.04 anyway? What are the drawbacks to using something like lvpm?

Should I just keep the wubi installation and not care?

Thanks

share|improve this question

2 Answers 2

up vote 1 down vote accepted

LVPM is by the same people who did wubi, It worked fine before, but apparently dosen't work with newer versions - which is probably why ubuntu complains about it.

If you REALLY need to be able to suspend/resume or something else ubuntu needs, switch over to a real partition. Else, really, if it works, there's no need to fix it, IMO

You can probably reinstall ubuntu fresh, and move over your home directory if you really want a physical install of it.

share|improve this answer
    
besides suspend/resume... what other things would I be missing? Would there be a big performance increase if I went with a fresh install? Anything of that nature? I am mainly programming when I am in Linux. I've already accidentally hit the suspend button and that was not fun :/ –  egervari May 11 '11 at 1:04
    
I can't really remember, I think that, and needing to shut it down PROPERLY to avoid bad things (tm) happening were the main issues i had. –  Journeyman Geek May 11 '11 at 1:05
    
I think I've had "bad things (tm)" happen to me already. Sometimes I boot into Ubuntu and the minimize/maximum buttons don't load up properly when I boot in sometimes. Other-times, I don't have sound (using an FA-66 audo hardware box) This sound problem is simply fixed by rebooting again :/ –  egervari May 11 '11 at 1:09
    
i've had sound issues on vanilla kubuntu installs before as well, you need to look up the command for restarting just the audio subsystem - in my case it was 'sudo alsa force-reload –  Journeyman Geek May 11 '11 at 1:24

Yes, you can.

No special skills needed.

There is a script to do it, and also an outstanding tutorial that not only tells you what to do but also helps you in understanding what is being done.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.