Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I can't reach websites using browsers in OS X 10.6.7 on a MacBook Pro, possibly after resuming from sleep. I've had this problem before and it has been solved by a reboot, but I since I got it again I wanted to get to the root of it.

It all starts with Chrome and Safari not being able to browse the Internet. Here's a list of what works and what doesn't:

Doesn't work

  • Browse Internet in Safari, Chrome and Firefox ("You are not connected to the Internet.")
  • Adium


  • ping
  • wget
  • curl
  • traceroute
  • nslookup
  • Browse Internet in any browser with the Charles proxy started
  • Browse (Google IP) in any browser
  • Skype

I haven't configured any proxy at all (except for when running with Charles). Other computers on the network can reach Internet just fine. I'm connected to either Ethernet, the AirPort, or both but no combination makes a difference.

I've also tried to use a different DNS provider, Google Public DNS, but that didn't work either (nslookup, ping etc used the new name server without problems).

Visiting the IP number of in the browser works as stated above, and considering ping et al works, it seems to be a DNS issue? What could be causing this?

share|improve this question
Have you tried using firefox? I mean it could be webkit but that's just another suggestions. – Muhammad Usman May 11 '11 at 8:00
@Muhammad Thanks for the tip, see my edits. – Adam Lindberg May 11 '11 at 8:06
up vote 8 down vote accepted

Problem temporarily solved by running:

sudo killall mDNSResponder

As per this question: MacBook can't use internet, but nslookup and ping both work.

Still doesn't explain why this breaks down on sleep/resume though.

share|improve this answer

Perform all these steps, checking after each whether the problem is resolved.

  1. Reboot your router

  2. Reset your Mac's PRAM

  3. In Terminal

    dscacheutil -flushcache
  4. In System Preferences/Network, create a new (non-duplicate) network location, and configure it for your needs

  5. In Terminal

    sudo launchctl unload /System/Library/LaunchDaemons/
  6. Patch the 4 mDNS system files back to 10.6.4


    There is even a package with the files.

    In this post he says that he is using the patch on 10.6.7.

    Nevertheless, backup your 10.6.7 files first.

    And confirm successful replacement of each file.

share|improve this answer
I'm running on Lion, and my mDNSResponder isn't crashing at all. That seems to be the issue the poster of that question was describing – Yuval Nov 1 '11 at 5:40
can you post results of scutil --dns ? – freebairn Nov 1 '11 at 11:07
Thanks for your response! Here ya go: What do you think? – Yuval Nov 4 '11 at 2:34

From OS 10.6 - Snow Leopard keeps dropping DNS :

I recently switched to a Mac running 10.6.latest as my primary machine and ran into this exact problem. I have a LAN-based DNS server to provide addresses for the other machines on the internal network and two DNS servers provided by my ISP. Intermittently, Firefox would fail to resolve the name of an internal server.

After some searching, I found this page that suggests Apple changed the way DNS servers are queried in Snow Leopard : Changes in DNS resolution in Mac OS X.

I found this article and made the suggested changes: OS X 10.6.3 and DNS server priority changes.

I hope this helps someone else get Snow Leopard to honor DNS server ordering instead of randomizing them.

share|improve this answer

If sudo killall mDNSResponder temporarily solves it, then you could create an Applescript to run when you resume the computer from sleep.

Try creating a new user on your computer and see if it works in that.

Phone up Apple -

share|improve this answer
The user offering the bounty wrote that the accepted solution did not work for him. – Daniel Beck Oct 26 '11 at 14:10
@DanielBeck Sorry. I have crossed it out. – gadgetmo Oct 26 '11 at 14:30
Thanks guys. Neither a new user nor does killing mDNSResponder works. All Apple gave me was the typical airport debugging advice, which didn't help at all. Any other ideas? – Yuval Oct 27 '11 at 5:59
I think this is worth noting, though: Charles Proxy does work. I have no idea why. If we can figure out what it is doing then maybe we can replicate it without using the program? I don't think it uses an actual proxy, but it somehow redirects the request to the localhost, which makes it work. Unless that is, that I'm wrong. Any ideas? – Yuval Oct 27 '11 at 6:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .