Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I don't want Firefox to display XML files internally, I want it to open Notepad++ instead.

I have had a look a the Tools\Options\Applications menu but there is no 'XML' content type.

I am using FF 3.6.2

Obviously this only applies to XML files that I click on in the browser, XML files opened from the file system do open in Notepad++.

share|improve this question

migrated from stackoverflow.com May 11 '11 at 15:38

This question came from our site for professional and enthusiast programmers.

up vote 1 down vote accepted

Holy cow! This issue drove me CRAZY all evening. I finally figured it out. I realize the original question was long ago, but I want this answer on the internet, so here goes:

Instead of adding an entry for XML, I had to update the extensions list for text/plain. Here is what the text/plain entry now looks like in my mimeTypes.rdf file. The file is located in the firefox profile folder, see firefox troubleshooting page (type about:support into the navigation bar) and under "Profile Folder" click on "Show Folder" then edit the mimeTypes.rdf file with notepad++.

  <RDF:Description RDF:about="urn:mimetype:text/plain"
                   NC:description="Text Document"
                   NC:value="text/plain"
                   NC:editable="true">
    <NC:fileExtensions>xml</NC:fileExtensions>
    <NC:fileExtensions>txt</NC:fileExtensions>
    <NC:handlerProp RDF:resource="urn:mimetype:handler:text/plain"/>
  </RDF:Description>

  <RDF:Description RDF:about="urn:mimetype:handler:text/plain"
                   NC:alwaysAsk="false"
                   NC:saveToDisk="false"
                   NC:useSystemDefault="false"
                   NC:handleInternal="false">
    <NC:externalApplication RDF:resource="urn:mimetype:externalApplication:text/plain"/>
  </RDF:Description>

  <RDF:Description RDF:about="urn:mimetype:externalApplication:text/plain"
                   NC:path="C:\Program Files\Notepad++\notepad++.exe"
                   NC:prettyName="notepad++.exe" />
share|improve this answer

You must configure XML file types download action to achieve what you want.

More info here:
http://kb.mozillazine.org/File_types_and_download_actions

share|improve this answer
    
Thanks for the link. I have now added text/xml and application/xml mime types to the mimeTypes.rdf file in my profile. The xml type now shows up in the Tools\Options\Applications and I've set the handler to Notepad++ but when I click on an XML link it still opens in the default xml viewer. Is the default viewer overriding this setting or am I missing something? Thanks – ChrisB May 11 '11 at 14:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .