Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Asus P8H67 motherboard (not sure it's very relevant, I have had this happen with other systems as well) -- I can't get the front panel 3.5mm jack to work. I know that it works, because I've tested it in Ubuntu. Windows 7 says they are "not plugged in", no matter what I do.

Playback Devices shows headphones as not plugged in

I know one workaround is to install some realtek bloatware and disable front panel jack detection (or something like that), but is there no other way?

share|improve this question
add comment

2 Answers 2

up vote 7 down vote accepted

The Realtek "bloatware" you speak of isn't really (solely) bloatware.

It is a driver needed to detect and use the front panel sockets - it also has a UI program that displays the status of the sockets and allows you to set a few other options. The program is low on resources.

You should install the driver, then if you do not want the UI, simply use MSConfig or Autoruns to stop it from starting with the machine.

share|improve this answer
    
What Wil said. You HAVE to install it. You can disable the services/tray icons. We do this specifically with these exact Realtek chipsets on machines we ship. –  Shinrai May 11 '11 at 19:00
    
+1, I agree with that (although driver != systray bloatware). However, even if I install it, is "disable front panel jack detection" the only option? It's the only one I can find, and, it's not pretty. If I leave that disabled, front panel jack detection never seems to work (I plug in headphones but nothing happens). Is it supposed to work? I could not get that to work on my previous machine either. –  Felix May 11 '11 at 20:11
    
I use the Realtek drivers on a desktop, and a laptop, and there is almost no footprint from it. Highly recommend using them, it brings out some great sound settings. –  Simon Sheehan May 11 '11 at 23:39
add comment

Download this program (HD Realtek Audio), it will fix your problem:

Realtek High Definition Audio Codec for Windows 7 and Vista (32-bit & 64-bit) R2.47

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.