Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

my logs contain currently two timezones, do you have an idea from where it comes and how to fix this? It's the first time I see this on a system.

The system is running inside a Virtuozzo container with CentOS 5.

Here is a small snippet:

May 11 13:51:37 dido sshd[13443]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=XXXXXXXXXXX  user=root
May 11 13:51:39 dido sshd[13443]: Failed password for root from XXXXXXXXXXX port 46038 ssh2
May 11 **11:51:39** dido sshd[13447]: Received disconnect from XXXXXXXXXXX: 11: Bye Bye
May 11 13:51:40 dido sshd[13467]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=XXXXXXXXXXX  user=root
May 11 13:51:42 dido sshd[13467]: Failed password for root from XXXXXXXXXXX port 46312 ssh2
May 11 **11:51:42** dido sshd[13473]: Received disconnect from XXXXXXXXXXX: 11: Bye Bye

As you can see, for the message "Bye Bye" it logged it with the UTC timezone instead of the GMT.

Thank you, Mike

share|improve this question
2  
GMT and UTC are same time zone, unless fractions of second are of extreme importance to you. –  AndrejaKo May 11 '11 at 21:25

1 Answer 1

The Process-IDs don't match, so it looks like there are separate sshd processes each picking up different timezone settings.

For example: do you have one sshd started from /etc/rc, inetd or xinetd and another started manually on a different port, started from an interactive session (with a local TZ setting)?

share|improve this answer
    
I have looked at setting the clock on CentOS, and after several digging I have found out one problem that happens during the boot sequence. The rc.sysinit script calls hwclock and since this is a virtual image (a virtuozzo container) the file /dev/rtc doesn't exist and the command actually fails. I ran a new sshd process by "hand" with a custom configuration file (on localhost port 2222) and when the connection is lost it stills store a "Bye bye" message with the UTC clock. I believe there is no way out of this, that it's a limitation of the virtualization of Virtuozzo. –  m8t May 13 '11 at 19:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.