Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have set up a lab environment in virtualbox with 1 workstation and several ubuntu servers behind a Smoothwall gateway. Sometimes, I forget to set a DHCP reservation and I will get an address from the dynamic pool. Once I do set the reservation, how can I force either the server or SmoothWall to send the reserved IP address.

I realize that I can manually set the interface of the server to a static IP, but I would like to get the benefit of being able to refer to the server by name and not IP address. Also if I need to change the IP address of the server, I would rather do it through DHCP instead of the configuration files.

share|improve this question

1 Answer 1

Best practices would state that the servers should have a static IP address. Once DNS entries for those static IP's have been created, you should have no issue resolving them by hostname.

If you truly want to give them reserved DHCP addresses, you will need to configure that on your DHCP server. DHCP reservations are based upon MAC addresses, so make sure that you have them when setting it up.

What is the OS of the server is giving out DHCP?

share|improve this answer
    
I do want to get around to setting up DNS. I was just using Smooth wall as a shortcut. To your second point, that is the main problem. Most of the time I will reserve the address before even setting up the server, but sometimes I forget. I would just like to force the address after the fact. Smoothwall is based on linux. –  charliebuckets May 11 '11 at 20:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.