Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a '3one data' brand serial-to ethernet converter, that plugs into a serial device at one end, and allows bidirectional communications with the device over an ethernet connection, like this:

enter image description here

There is supposedly a way to set up a virtual serial port in Ubuntu, which maps a /dev/ttyXX entry to the IP and port of this device and allows transparent communication with the real serial device on the other end. Unfortunately there was no linux documentation accompanying this device, despite the fact that linux support was prominently advertised.

I am struggling with setting up this virtual serial port in Ubuntu, which I believe should be achieved through the ttyd command. However, with the device connected (I can telnet into it directly), if I run:

sudo ttyd -d /dev/ptyp1 50000 -b 115200 -p 8NC0

my understanding is that a new virtual serial device should be created, /dev/ttyp1, but this doesn't happen. The ttyd command above does not throw any errors.

Is this possible, or should I be using a third-party driver of some kind?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I could be wrong, but I think you need a kernel serial driver to talk to that type device.

The only ethernet to serial converter that I have found that supports linux at all is the lava-link brand.

They have a GPL'd kernel driver on their site for a 2.4 kernel. We fixed 2 bugs in it and resubmitted it them but it is not available on their site yet--if you go with a lava-link, or just want to look at it, I can send you our fixed copy of the kernel driver.

We then use an "action" in Konqueror to run a script to either upload to or download files from remote serial ports on CNC machine tools.

share|improve this answer
Thanks for the answer! I ended up getting another device, a Moxa Nport 5250A Serial Device Server, which has drivers for 2.4-2.6 kernels. It seems to be working well. I'm sure the original 3one data device would have worked if they actually wrote a driver for it. –  jozzas Oct 5 '11 at 23:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.