Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Ubuntu 9.04 installation on a computer with 2GB RAM I want to upgrade to 4GB.

First, I had 1GB of Swap. When I tried to hibernate, linux said that my Swap wasn't big enough.

Ok, ok, I increased it, now I have 8.06GB of Swap. It can't complain about space!


UPDATE:

The problem just after this update is already solved. I should unload manually the bluetooth USB (btusb) module.

But it keeps not working. It shows me no error when I try to hibernate, looks like it is working. But when I turn on the computer it's like I haven't hibernated it before.

When I try to hibernate I got this screen sometime before the computer shuts down:

enter image description here

Can someone help me out?

share|improve this question
add comment

2 Answers

The "btusb" prefix tells you that the error originates with the Bluetooth drivers in your kernel. Run "lsmod" to see your kernel drivers and look for btusb. (Or just "lsmod |grep btusb".) If you have a Bluetooth device, try running "rmmod btusb" to unload the driver and then try to hibernate again. (If you have a Bluetooth keyboard or mouse, connect a wired substitute first.)

If it works, you have at least isolated the problem, and you can try the workarounds from the forums nagul linked above.

share|improve this answer
    
So, i think the problem is with that bluetooth micro-dongle I have attached at my computer 24/7. I'll try to unload the btusb and hibernate. –  Igoru Aug 23 '09 at 22:08
    
It didn't work =( I unloaded the module, and there was no errors while hibernating. But when I turned on the computer it powered on normally, like if I had powered it off and hadn't hibernated. –  Igoru Aug 24 '09 at 11:26
    
Okay, now you want to look into swap issues. Use "swapon -s" to see the size and locations of your swap partitions. Make sure your new swap partition is listed in /etc/fstab and that it mounts on startup. –  mikedub Aug 24 '09 at 23:05
    
Once you've checked on the swap, look at /etc/initramfs-tools/conf.d/resume and make sure the UUID matches your swap partition. –  mikedub Aug 24 '09 at 23:09
add comment

There are plenty of people with issues getting hibernate to work. Have a look at this two links and see if you have anything in common with the people who participated in the bug report and forum post:

There is no single underlying problem, but rather a bunch of different issues, with an equally disparate bunch of fixes, so I'd be hesitant to guess what the exact problem with your setup is.

If you find something that mirrors your setup, you might want to give the suggested workaround (if any) a try.

We might be able to help you better if we had details of your system hardware.

share|improve this answer
    
take a look at my comment at the other answer =D –  Igoru Aug 23 '09 at 22:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.