Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For some reason when I do Start, Run, cmd, Enter it always starts at M:, one of several mapped network drives.

I'd rather have it start on C:, or in C:\dev if possible. Is there a way I can fix this?

share|improve this question
3  
It could be that drive M: is mapped as the user's "home" folder. – Majenko May 12 '11 at 8:20
    
@Matt: Yeah, that actually seems to be the case. So I suppose that's why it starts there :) – Svish May 12 '11 at 8:33
up vote 4 down vote accepted

Create a shortcut to cmd.exe (on the desktop or in your Start menu) and right click on it, select properties. I've forgotten what it's labeled in XP, but in Windows 7 it says "Start in:" put your directory in that box.

For a more permanent solution, you can edit the registry and change the HKEY_CURRENT_USER\Software\Microsoft\Command Processor's Autorun value. See this for details.

share|improve this answer
1  
Used the shortcut trick. Worked perfectly, and doesn't mess with default behaviour and registry stuff :p – Svish May 12 '11 at 8:32
    
@Svish great! :) – jonsca May 12 '11 at 8:34

Check the registry key HKEY_CURRENT_USER\Software\Microsoft\Command Processor, item Autorun.

If Autorun contains something like CD /d M:\, just change it to CD /d C:\dev.
If not, then let me know its value on your computer.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .