Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows XP, and last night my PC was infected by a frustrating virus (one of those viruses that won't let you open virus checkers, etc). I finally killed it 2 hours later, but it involved some heavy duty anti-dote. One side effect is my audio is now gone.

Except it's not entirely gone, because when I open the Realtek HD Audio Manager in the task bar, I can play all the "test" sounds. The speakers, the sound card, etc, are therefore working fine.

But things like YouTube or Windows Media Player, there's no sound.

I'm guessing there's a setting that needs to be reconfigured somewhere.. but where?

Maybe relevant: One thing I did do last night was "play" with the system registry.

Any help would be greatly appreciated.

Thanks.

SOLVED!

The two hour battle with my computer virus resulted in my computer permanently thinking it was in Safe Mode, regardless of how it booted up.

I was able to "fix" this by following the post by hsandler in this thread: http://www.petri.co.il/forums/showthread.php?t=23032&page=2

I then rebooted.. and let me tell you, the Windows Startup music has never sounded so sweet.

Thanks to all, especially James, whose advice gave me a major clue as to what the problem was.

share|improve this question
4  
Don't want to distract from the "interesting problem" angle this question might take, so just as acomment: Why didn't you just format and re-install Windows? Would have been a lot faster and less of a pain. –  Tobias Plutat May 12 '11 at 11:11
1  
I was gonna suggest the same thing as @Tobias. The hours you will spend trying to hunt down this error might be more than the time needed to set up a system again. Also, maybe have a look at my answer here in order to keep the system clean. –  slhck May 12 '11 at 11:22
    
It would be nice if you could put the solution in an answer and accept it :) –  Oliver Salzburg May 18 '12 at 15:35
    
@OliverSalzburg, he has 6 rep (1 auto and 1 Q↑) and has not been back for over a year. This was clearly a hit-and-run troubleshoot, so I don't think they'll be doing that. –  Synetech Jul 18 '12 at 2:54
    
@Synetech: Thanks. That is very valuable information. –  Oliver Salzburg Jul 18 '12 at 9:09
show 2 more comments

4 Answers

Go to Control Panel -> Sounds and Audio Devices then click the Audio tab. Try selecting different options from the Default Device drop down list within the sound playback section, remembering to click Apply each time before testing.

If that doesn't work there are lots of other options on the Sounds and Audio Devices screen to try if you haven't already done so. Be sure to check all the volumes.

share|improve this answer
    
Hi James, everything in the Audio tab is greyed out. –  Callum May 12 '11 at 12:29
    
Right-click My Computer and choose Properties. In the new window click the Hardware tab then click Device Manager. Have a look under the Sound, video and games controllers section and let me know what devices are shown. Are any of them showing errors? –  James May 12 '11 at 12:38
    
No errors: Audio Codecs, Legacy Audio Drivers, Legacy Video Capture Devices, Media Control Devices, Realtek High Definition Audio, Video Codecs. –  Callum May 12 '11 at 12:46
    
Also try the following: Start-> Run -> Services.msc then look for a service called Windows Audio. What is its current status? If it shows as stopped then right-click and choose start and test the audio. –  James May 12 '11 at 12:46
    
Did it, and it's thrown a CLUE. I tried starting Windows Audio, and the error said "Can not start while in Safe Mode". My computer thinks it's in Safe Mode. Since taking the virus off, the desktop appearance has changed a bit to look more like Safe Mode, but it doesn't look like the proper safe mode. I have booted in to the "proper" safe mode numerous times today since I lost the audio. I have also restarted the computer and explicitly chosen "Start Windows Normally", same deal. Any ideas.. ?! –  Callum May 12 '11 at 12:56
show 7 more comments

Make sure you have your speakers set to default. If not, depending on your configuration, this could make them produce noise during the sound test but not with anything else. If they are set up as your default device then another device, like digital audio, may need to be disabled.

I deleted the picture and clarified my statement in case it was confusing.

share|improve this answer
    
Blomkvist, how do I access this screen? –  Callum May 12 '11 at 11:58
    
Callum has stated that he is using Windows XP which does not have this screen –  James May 12 '11 at 12:03
    
The screen is irrelevant, it was there to illustrate a point. –  Blomkvist May 12 '11 at 12:13
add comment

You probably need to configure your audio device once again and it will work. I had the exact same issue with my logitec speakers, was getting sound when using the test button but nothing else worked. Well when you click on setup your device, in this case you have to choose between stereo quadriphonic 5.1, 7.1 ch. After runing the 5.1 configuration and trying to listen to a song, IT WORKEDDD !

Hope it might help someone.

share|improve this answer
add comment

Next to making sure it's the default output and speaker configuration; If you have changed the audio format in Advanced, try setting the format to 16bit-44100khz or 16bit-48000khz.

This is what most software will support.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.