Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to setup openVPN on debian, well this worked. But every client will get the same ip (172.17.0.6 - local it is).

I have no idea how to set my server in bridge mode. I've read about:

server-bridge LOCALIP 255.255.0.0 172.17.1.20 172.17.1.100

BUT, my server has no ipv4 address, but only ipv6: 2001:41d0:2:b2d6::542a:74a so I am not sure how I can do this.

Anyone can give me advice? Thanks in advance!

share|improve this question

1 Answer 1

up vote 0 down vote accepted

You should read this information from the OpenVPN FAQ:

  OpenVPN - FAQ - Is IPv6 support planned/in the works?
  http://openvpn.net/index.php/open-source/faq/77-server/287-is-ipv6-support-plannedin-the-works.html

Essentially, it indicates that you probably need to be using TAP mode instead of TUN mode for now. Which one are you using? You can find the answer in either the server or client configuration files (see the "dev" directive).

share|improve this answer
    
Thanks, I've set it to tap now. Although I cannot browse the internet due to not having a DNS server. I've installed bind locally, and using push "dhcp-option DNS 127.0.0.1" doesn't work. Neither doe spush "dhcp-option DNS 8.8.8.8" (Google's DNS). Am I missing something? –  Devator May 13 '11 at 10:34
    
@Devator: Why not run ISC-Bind on your OpenVPN server? That way you can push the OpenVPN server's IP address as the DNS server. The default configuration for ISC-Bind is usually well-suited for working as a caching name server to provide resolution to users. –  Randolf Richardson May 13 '11 at 15:25
    
Ok so I am running in TAP mode now, but still I'm unsure on how to set this thing up. –  Devator May 15 '11 at 16:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.