Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have missing images in Firefox and IE. While most of the website works, there are images that just won't load in these two browsers. I just installed Chrome and everything is working fine. What gives?

I've checked that 'automatically load images' is checked in the Firefox/IE options but I can't put my finger on what other settings could cause this.

pictures broken

Notice below the picture of the red car. There are three blank squares that should be back, pause and forward buttons but they're not there. There should be a blue bar under the search box that colors the 'news, entertainment, sports...' bar but it's not there. The red car shows up just fine, but some other pictures do not.

share|improve this question
What versions of IE/FF? (As in maybe the site is using code not supported by your browsers. I can "hide" the buttons entirely by blocking JavaScript from the domain, but that looks to be different from your situation.) – therube May 13 '11 at 6:06
I think it's IE8 and FF3.6 – blsub6 May 13 '11 at 16:31
I would certainly like to know what happens if you directly open these images? Like, you copy the URL and put it into the address bar of both FF and IE. – sinni800 May 17 '11 at 10:54
Have you tried to run the IE and FF without activated add-ons? Also I would like to know which av system you use, some systems are known for causing problems like this. – Michael K May 17 '11 at 12:35
In FireFox, if you right click on the image's location and select "View Image", do you get to see the image? What about Tools->PageInfo->Media - do you see the images there? – BIBD May 17 '11 at 14:16

11 Answers 11

Try this in Firefox:

  • Go to Tools (alt + t) -> Options
  • Click the Content tab
  • In the Fonts & Colours section click the Colours... button
  • Make sure Allow pages to choose their own colours, instead of my selections above is checked

If I uncheck that option on my machine then I can replicate your symptoms. Obviously this does not affect Internet Explorer so I don't know for sure if it will help. But this check would at least rule out browser settings.

If it doesn't work then I would need more information:

  • What other sites are particularly affected?
  • Who is your internet provider and are you accessing the internet through a proxy? Is it mobile broadband?
  • Are any other machines using the same connection and are they affected as well?
share|improve this answer
Who downvoted this and why? – James May 18 '11 at 11:14
Ditto. Looks like someone went -1 happy. +1 – BIBD May 18 '11 at 14:13
This worked on my computer too. I changed the Windows 7 theme and it fixed the problem in both IE and FF so maybe that setting is played with by the theme...I wish I could have two answers to one question but because I can't award it to my own answer, you get it :) – blsub6 May 18 '11 at 16:55
up vote 3 down vote accepted

This was a theme issue.

The user had changed his Windows 7 theme and broke those images. I noticed that an MSE popup was not the color that it should have been and the sticky notes that he had on his desktop were white in the middle when they should have been yellow all the way through.

I set the theme back to Windows 7 (the default) and it fixed the issue. I don't know what happened when he changed it back, but ultimately the theme was the issue

I don't have any idea why

share|improve this answer

Interestingly enough, it seems like Google Chrome sometimes ignores the Windows "hosts" file (source), whereas Internet Explorer and Firefox obey it. So, you might have an entry in your hosts file that blocks certain images, e.g. offsite images that belong to a different domain name, then Windows might not be able to connect to them.

Try checking your hosts file (by default; %WINDIR%\system32\drivers\etc\hosts) and look for anything suspicious.

If your unfamiliar with your hosts file, it should only contain localhost

by default, as well as comments (lines that start with semi-colons)

share|improve this answer
looks like the hosts file is untouched – blsub6 May 17 '11 at 22:14

Load up Firebug in Firefox and take a look at the 'net' tab. Reload the page and see what '404's' you get. This test will enable you to see if it is a browser problem (images served but not shown) or a server problem (images requested but not served).

Different browsers can respond differently to errors in the stylesheet, a missing semi-colon can be ignored by one browser but cause problems in another. Consider putting your stylesheet through an online validator such as or, with the developer toolbar (Firefox) see what errors arise in the CSS.

share|improve this answer

a friend of mine got the same problem on his windows box and solved it for firefox following the last post here which I summarized for you :

Firefox -> go to address about:config

set network.http.max-connections to 6 and network.http.max-connections-per-server to 2 finally set network.http.pipelining to true

I don't know what to do with IE though...

share|improve this answer
Activating the pipelinig just causes the browser to load multiple objects the same time instead of loading them in a row. – Michael K May 17 '11 at 12:33

I would guess you've got some web filtering software installed, perhaps as part of a larger AV suite, and it installed a plugin for IE and FF but not Chrome.

share|improve this answer
MSE's the AV and it doesn't look like he has any unknown plugins installed – blsub6 May 17 '11 at 22:17

Why don't you try upgrading to FF 4.0 and see if you get the same results? if you do, I would do a clean install of firefox by uninstalling firefox (use revo uninstaller) and downloading the latest version

This would at least determine if it's the browser or something else causing the problems

share|improve this answer

The elements that you are complaining about are either generated by scripts or placed there by style sheets. I have scripting turned off by default on my FF, and I don't see those three images (controls) below the red car until I turn it on - but I do see the blue bar under "news, entertainment, sports...."

By looking in Tools->PageInfo->Media, I found that the image for the controls are stored in (this may vary for your session). This doesn't show up in my view source, so that would suggest to me that it's coming from one of the .css or .js files - but it looks like they've done their best to obfuscate that.

share|improve this answer
Wow, I'd like to know what was so bad about this answer to deserve a down vote. – BIBD May 18 '11 at 14:10

Having the same problem as blsub6 using IE7 and FF4.0.1, but NOT with Chrome, I just learned that looking in Tools->PageInfo->Media, I found the following... is the location of the IMAGE for more than 20 of the functions on my hotmail inbox using Firefox; can't find this info in IE, as I RARELY use it. Unfortunately that "clear" means what it says...mothing visible there. NOW, can someone tell me where to find what SHOULD be there? Thanks for all the above; they helped me get HERE. Additionally, this problem has existed with several earlier versions of FF and om many different web pages.

share|improve this answer

I had the same problem that really caused me headache since last night. I saw this post and tried everything suggested here but nothing worked, so I searched more and found this website

and it worked.

I came back to this post because I wanted to help and I hope I will.

share|improve this answer

I can't really speak for Firefox, but in Internet Explorer make sure that "protected mode" is turned off.

We call that the "make nothing work" mode in the office and 99% of the time if you run into a weird Internet Explorer error, it can be fixed by turning that option off and rebooting.

share|improve this answer
yeah, the settings are actually lower than what they should be. I think I have the security set to medium and the privacy set to medium. No protected mode to be found – blsub6 May 13 '11 at 16:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .