Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have:

Internet Router: SpeedTouch 585

2nd Router: DLink DI-604

When connecting my computers directly to the SpeedTouch internet works. But when connecting the DLink to the SpeedTouch, and computers to the DLink, I get no connection. What I need to do to make this work?

I'm running XP on one laptop and Win7 on another, same issue on both.

share|improve this question
    
Can you reach the other computers while connected through the hub? –  slhck May 13 '11 at 8:33
    
Yes, I have a home network I use for sharing files. With XP / XP this worked both ways. Now I installed Win7 on one, so have Win7 / XP, and I can see the XP pc from Win7, not other way, but I think that's a different issue. –  user76193 May 13 '11 at 8:44
    
Hm, it should work without configuration actually. Can you ping the router? Are you using DHCP or static IP addresses? –  slhck May 13 '11 at 8:51
    
Yes I can ping the router, and log on to the SpeedTouch setup. Not sure if I'm using DHCP or static, where can I find out? –  user76193 May 13 '11 at 8:56
1  
A hub is a dumb network device that lets everything go everywhere, a router/switch requires setting up and some can't be used as a network extender. I hope your lucky with this one. –  Tog May 13 '11 at 9:21

1 Answer 1

up vote 1 down vote accepted

Judging from the fact that

  • You can reach all other computers
  • You can reach the other router and its setup page
  • Your connection settings seem fine

My suggestions:

  1. Make sure that you connect the routers using one of the DLink's 4 LAN ports and not the single WAN port that should be used for connecting to the modem.
  2. Also, you should enter the IP address of your first router as the gateway, otherwise the computers won't know where to "look for their internet connection".
  3. You should disable DHCP on one of the devices. Most probably it's running it on both, which can cause serious confusion. I'd disable all kinds of network services on the DLink, as it then merely acts as a switch.

enter image description here

share|improve this answer
    
Which router you mean? I connect SpeedTouch LAN1 port, to DLink WAN port. Then computers to DLINK LAN1 and LAN2. Is this wrong? –  user76193 May 13 '11 at 9:23
    
Yes, don't connect it to the DLink's WAN port, but to one of its LAN ports. –  slhck May 13 '11 at 9:26
    
It works! :) Using the LAN port, specified gateway address on both computers, and reseted the DLink. The DHCP I can't seem to be able to change. All buttons are disabled. Or maybe that is set up in the router? –  user76193 May 13 '11 at 9:53
    
If the buttons are disabled it might be disabled anyway, so that's fine :) If it's running, leave it at that. If my solution worked for you, consider accepting the answer so the question is closed. Glad I could help. –  slhck May 13 '11 at 9:54
    
Yea, idk, it looks like this img156.imageshack.us/img156/5420/ss20110513125841.png Ok, thanks for the help! :) –  user76193 May 13 '11 at 10:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.