Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just need a browser that can run sites using ActiveX on Linux. Are there any?

share|improve this question
add comment

4 Answers

up vote 2 down vote accepted

From Firefox Help:

ActiveX is a Microsoft technology that is used to add functionality to Windows programs.

ActiveX "controls" are often used to enable Microsoft's Internet Explorer browser to view and use multimedia content embedded in web pages (for example, Flash applications). They are also used to add new functions to the browser (for example, toolbars).

Firefox does not support ActiveX technology for multiple reasons.

  • ActiveX is only available on Windows operating systems, and as a result webpages that require it will not work on Linux or Mac.
  • ActiveX integration with the Windows operating system has made it a target for malicious software (Malware).

So your best bet would be to use IE via Wine.

share|improve this answer
    
Mepher, that advisory is applicable to Windows, not Linux. –  Blomkvist May 13 '11 at 18:26
    
I don't know if it was ever updated, but there was a plug in available way back in FF2 or 3 that allowed it to use Active X controls. But again, it would have only worked for Windows. –  BBlake May 13 '11 at 18:44
    
@Blomkvist: Did you read my whole post? That's why I say "use IE via Wine". –  Mehper C. Palavuzlar May 18 '11 at 17:13
add comment

Have you tried IE in wine? I have to do this for my IP cams that only work with activeX. Here's something that may help.

share|improve this answer
add comment

ActiveX is for Microsoft and Microsoft only.

Firefox has its own engine to incorporate additional functionality i.e. plugins

share|improve this answer
add comment

My experience with the FF IE engine plugins (on Win machines) to provide IE functionality have been that it relies on the presence of an installed instance of IE ... so if IE is not installed or broken, those "IE engine" plugins wont work.

There are some activeX apps I've had to use, and have had my problems using them in certain machines and their installations of IE, so tried the FF IE engine plugins, same exact problems. Once the problems are finally fixed on IE itself, the FF IE engine plugins finally worked.

So it's all brought me to understand that a working IE is needed on the machine for the FF IE engine plugin to work correctly.

So Wine and IE seemed to be the answer.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.