Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Arch Linux, and I just upgraded to GNOME 3 with GNOME Shell. I have a KVM switch, which says in the instruction manual to press the Scroll Lock key twice to switch modes. Scroll Locks has never worked for some reason, but pressing Num Lock did work.

Anyway, since I upgraded to GNOME 3, nothing works to switch modes. The indicators on my keyboard say that the button itself is working, but something is different about GNOME 3 that is preventing my KVM from switching.

Anyone know what the problem might be?

share|improve this question
    
Is the KVM a belkin? If so it should be scroll lock twice then the up or down arrow to cycle. –  Blomkvist May 13 '11 at 22:49
    
It's a Trendnet KVM switch TK-209. –  arussell84 May 13 '11 at 23:11
    
Lol. Swing...and a miss. They claim they'll help you with linux issues if you email them so if it turns out no one here can help you might give that a shot. –  Blomkvist May 13 '11 at 23:29
    
@Blomkvist The fact that they say they support Linux is the reason I purchased their brand. Let's hope that they are true to their word. =) –  arussell84 May 13 '11 at 23:53
    
I'm rather surprised that any KVM switch needs any cooperation from the OS, it sees the keyboard scancodes before the OS does. –  RedGrittyBrick Nov 17 '12 at 20:18
add comment

5 Answers 5

If using any of the usb kvms by Trendnet like TRENDnet Tk-409, TRENDnet Tk-407 etc on linux distros Install numlockx then use numlock + numlock to change to another pc.

share|improve this answer
add comment

I wrote the following script, and it works. My TRENDnet Tk-409 works with numlock + numlock.

Doing a web search, I've found this. Install numlockx.

#!/bin/bash
numlockx off;sleep 1;  numlockx on; sleep 1; numlockx off

I don't know how to associate to a key stroke yet.

share|improve this answer
add comment

I had a similar situation a few years ago when I switched from Windows XP to Vista. A USB KVM I had would not work with the keyboard I had with Vista installed. I wound up purchasing a new keyboard. I had a Razer Tarantula which I replaced with a Saitek Cyborg, and then the switching feature worked fine.

I think, but am not 100% sure, that during the course of my testing I had gotten the Tarantula keyboard to work on the mouse port of the KVM, but then of course I couldn't use the mouse.

share|improve this answer
add comment
up vote 0 down vote accepted

I've contacted customer support regarding my Trendnet TK-209, but they haven't been able to find a solution. I doubt I will be able to resolve this issue. I'm marking this answer as a community wiki, so if anyone does find a solution, feel free to edit my "accepted" answer.

share|improve this answer
add comment

I have just found out with my Level-One and exactly the same issue (and my Hostkey is Scroll Lock + Scroll Lock

Using LevelOne KVM-0422) you can workaround that problem with:

Numlock, Scroll Lock, Numlock, Scroll Lock

The sequence has to be fired within the 2 Seconds, but it works beautifully for me now.

share|improve this answer
    
The OP doesn't have a LevelOne KVM –  RedGrittyBrick Nov 17 '12 at 20:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.