Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running on OSX Snow Leopard. Using ruby -v I see I have 1.8.7 and using rails -v I have 2.3.5

When I try gem update rails I get the following error:

bundler requires RubyGems version >= 1.3.6

share|improve this question

migrated from stackoverflow.com May 14 '11 at 6:17

This question came from our site for professional and enthusiast programmers.

    
possible duplicate of Need help to upgrade my rails version – Blender May 14 '11 at 5:53
1  
He's upgrading an application, I just need to update the version of rails installed. Also he's on a Windows machine, and I'm on a mac. In addition that thread is a year old and has items specific to that version which are now out dated. – Jhorra May 14 '11 at 5:56
    
See my answer (below) – Blender May 14 '11 at 6:01
1  
A question: why was this question migrated from stackoverflow to superuser? It's clearly about software development (and the related things that go with it, such as how to configure X dev environment). – Zabba May 14 '11 at 7:00
    
@Zabba: probably they confused SuperUser and ServerFault; this is not software development questions either. – Lie Ryan May 14 '11 at 11:17
up vote 1 down vote accepted

I suggest using rvm instead of trying to mess with ruby that comes default with Mac os

share|improve this answer

The error message you're receiving is because the new version of Rails requires a newer version of gem than you have. You can update gem like this:

gem update --system

You may need sudo if you're using system gem. You can check the version of gem by running:

gem -v

Once this is done, and you can confirm your gem version is at least 1.3.6, you should be able to run:

gem update rails
share|improve this answer

From my comment, you can upgrade rails by this command (I hope):

sudo gem install rails
share|improve this answer
    
When I try install rails or update rails I get the following error: bundler requires RubyGems version >= 1.3.6 – Jhorra May 14 '11 at 6:07
    
Run dis: sudo gem update -V – Blender May 14 '11 at 6:08
    
I ran that and it seemed to work, but I still get the above error – Jhorra May 14 '11 at 6:11

I don't know if you have Brew or Macport:

If you have Brew installled then you use the following command to install:

sudo gem install rails

or

brew gem install rails

Please go through this link:

http://hivelogic.com/articles/compiling-ruby-rubygems-and-rails-on-snow-leopard/

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .