Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have the following script working Emacs Auto Indent Mode

it does auto indenting but it has one problem when i start marking regions and go down by lines each time i hit the indention the marking is canceled and it kind-of annoyance me.

How can this be fixed or are there any alternatives? or how can i disable auto indention when marking region is active

share|improve this question

1 Answer 1

up vote 1 down vote accepted

It sounds like you have Transient Mark mode enabled. Try putting this at the bottom or your ~/.emacs file:

;; Turn off Transient Mark mode.
(transient-mark-mode -1)

and restart Emacs.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.