Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently installed the arm-uclinux toolchain from arm-uclinux-tools-base-gcc3.4.0-20040610.sh . I ran the script and tried to compile a test program:

/usr/local/arm-uclinux-tools/bin/arm-uclinux-gcc hello.c -o hello

/usr/local/arm-uclinux-tools/lib/gcc/arm-uclinux/3.4.0/../../../../arm-uclinux/bin/ld.real: crt1.o: No such file: No such file or directory
collect2: ld returned 1 exit status

I searched for hours about this issue and found nothing, except a hint about uclibc not being installed. Isn't it compiled along with the toolchain?

I'm using Ubuntu 11 64 bit.

share|improve this question

1 Answer 1

Take a look at this thread. If you'd rather just skip to the point, here's a quote from it

"Try using the command g++ instead of gcc. The g++ command is used for compiling C++ code (whereas gcc defaults to C code), and will automatically link against libstdc++.so. If you really want to use gcc to compile, you must manually tell it to link against the c++ library, e.g. "

$ gcc foo.cpp -l stdc++
share|improve this answer
    
What does libstdc++ have to do with the main C runtime object not being found? –  Ignacio Vazquez-Abrams May 14 '11 at 13:34
    
Nope, same problem with -l stdc++ :( I'm just compiling C anyway, so this shouldn't be a problem... –  Hamish Milne May 14 '11 at 13:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.