Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to have my development environment synchronized, so I installed NetBeans 7.0, GlassFish 3.1 and JDK 6u25 in a Dropbox folder.

The IDE works fine after setting up /etc/netbeans.conf:

# ${HOME} will be replaced by JVM user.home system property
netbeans_default_userdir="../../.netbeans/7.0"
# Default location of JDK, can be overridden by using --jdkhome <dir>:
netbeans_jdkhome="../../Java/jdk1.6.0_25"

However, I don't have any options under servers. Is it possible somehow to tell NetBeans to use a relative path to find GlassFish?


Oh actually, there's no problem adding GlassFish with a relative path, however JavaDB needs derby to have an absolute path :( Any suggestions?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Two questions:

  1. Did you install the appserver with installer? Maybe extracting it from an OS independent package will be a better option.

  2. Did you succeed with registering glassfish with the IDE. If the IDE can manage the server, it will for sure manage the built-in database.

I'm already using a development stack of this kind on three machines and blogged with more details about my experiments.

I hope you'll figure it out.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.