Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I cannot complete command or file name in my cmd using the TAB key. When I press TAB it actually inserts a TAB space. What have I modified from default settings?

I am using Windows 7.

share|improve this question
add comment

1 Answer

up vote 6 down vote accepted

The completion character is configured in Registry. Open regedit, navigate to the key HKCU\Software\Microsoft\Command Processor, and make sure the value CompletionChar is set to 9 (0x9). If such a value doesn't exist, add it (right-click - New - DWORD value) and enter 9 as data.

A possible cause for this is that the system-wide settings (HKLM\Software\Microsoft\Command Processor) have the completion character set to 64 (0x40) by default, effectively disabling completion unless per-user settings override it. If you want, you can change the system-wide setting to 9 (0x9) too.

share|improve this answer
    
Thanks! Worked like a charm! This is a recent problem, suggesting that something I might have installed or modified changed my system settings. –  Benny May 14 '11 at 18:19
    
@Benny: user settings. Although I can't imagine why any program would want to change that. Did you find the value in HKCU gone entirely, or just with a different data? –  grawity May 14 '11 at 20:01
    
The value did not exist at all. I had to create it. –  Benny May 15 '11 at 5:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.