Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I'm trying to be able to SSH to my desktop again after moving to a new house. I had this working before. The problem is, it works perfectly just using the local IP, but then when I use the WAN IP I get password denied:

***.org's password:

Permission denied, please try again.

***.org's password: 

Permission denied, please try again.

***.org's password:

Permission denied (publickey,password).

'* **' being my domain. But I know my password is right, and it only started not working once moved to my new house, and again it works locally. If I turn off port forwarding then of course it doesn't even connect to the host. So I know its at least connecting to my desktop, or at least something changes.

So my question is, since it works locally, and stops working altogether when I turn off port forwarding, what can I do to fix this?

share|improve this question
    
Can you add the output of ssh -v user@host when connecting to your question? It helps finding the issue. –  slhck May 14 '11 at 22:52
    
ssh -vvv will display even more details –  vtest May 14 '11 at 23:27

2 Answers 2

The first place I'd check is the /etc/hosts.allow file. It can limit what IP's have access to your SSH server.

share|improve this answer

A few things to try: 1) In your /etc/sshd/sshd_config file, make sure that you have 'PasswordAuthentication' set to 'yes'.

2) Compare the ssh public key in ~/.ssh/known_hosts for the SSH server on both the local machine you are connecting from and the remote machine that you are trying to connect from. The public key should be the same on both, otherwise you're not connecting to the say server.

3) Make sure your WAN device is set to do port forwarding on port 22 to your SSH server, otherwise you might be connecting directly to your WAN device.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.