Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On my Linux system, I want to create a symbolic link to a folder on my Windows 7 partition formatted FAT32. I use:

sudo ln -s /media/OS/Users/dennis/AppData/Roaming/.minecraft ~/.minecraft

However, I end up with a file in my home directory called .minecraft and when I try to access it, I receive:

bash: CD: .minecraft: Too many levels of symbolic links

is there a way to make the symbolic link to the FAT32 folder?

share|improve this question
What says df -k /media/OS/Users/dennis/AppData/Roaming/.minecraft ~/.minecraft and ls -ld /media/OS/Users/dennis/AppData/Roaming/.minecraft ~/.minecraft ? – jlliagre May 15 '11 at 6:20
Don't sudo this. Just rm ~/.minecraft and then do the ln -s ... above – Turbo J May 15 '11 at 7:49
up vote 0 down vote accepted

As long as your home directory is not on FAT32 or similar, you should be able to create a symbolic link to any file located on any file system and even to non existing files actually. There is no need to be root as long as you are allowed to create a file, which should obviously be the case with your home directory. I suspect ~/.minecraft already was a bogus link.

share|improve this answer
I think that was the problem. I deleted the ~/.minecraft and then tried Turbo J's suggestion above and it worked fine. – Dennis Hodapp May 15 '11 at 15:47

I don't believe you will be able to create such a link.

share|improve this answer
Wrong! The link will be on the ext? Filesystem, where you can basically make a link to any target including non-existent ones. – Turbo J May 15 '11 at 7:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .