Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Whenever I try to access other computers on my network, it fails to connect. If I ping the computer names (for example, "ping fileserver"), it always shows this:

Pinging [] with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Why is this happening?

share|improve this question
I found a new clue. This is my work laptop, so it is on our corporate domain. When I'm at work, "ping fileserver" returns "Ping request could not find host fileserver", which is not unreasonable. So, this DNS problem is either caused by my work domain, or the problem is being hidden by my work domain. – Josh Yeager May 16 '11 at 19:32
I had to reinstall Windows on my PC, for other reasons. This problem still happens. I'm completely baffled now. – Josh Yeager Jun 4 '11 at 1:21

Your DNS server is returning the addresses for Amazon.

What is the IP address of your DNS server?

Is it possible that you are using Amazon's registered addresses on your network behind a NAT and that the DNS is outside the NAT and therefore knows that these are really not your addresses?

Given that you have a DNS server IP address, I think it is safe to assume that the problem is on the device with that address. And since the DNS server is on the router/firewall, I suspect that the problem is that the DNS cache on that device has been poisoned. Try restarting it.

The reason that the other computers don't have a problem is because each computer keeps its own local cache of DNS results for some period of time. So they will not show the problem immediately unless you reboot one of them. The computer with the problem was probably rebooted more recently than the others.

share|improve this answer
My DNS server is my wireless router ( From any other computer, "ping fileserver" returns the correct IP address for that server. From this computer, it gets a completely different IP and the name. – Josh Yeager May 15 '11 at 3:03
The correct IP for "fileserver" is So, it's not an Amazon registered address. Other than the hosts file, are there any other places in Windows that name resolution can be messed with? – Josh Yeager May 15 '11 at 3:05
You may very well have botnet software hijacking your machine and messing with the DNS internally, for instance it may be redirecting all DNS traffic via a network device driver so your Windows config is not relevant – Michael Dillon May 15 '11 at 3:19
I just ran scans in Windows Defender and Malwarebytes, and both say my system is clean. Any tips on how to verify that? – Josh Yeager May 15 '11 at 4:07

If you've checked the hosts file and found nothing, try running the following command in a Command Prompt:

ipconfig /flushdns

This will flush the DNS cache.

share|improve this answer
Yeah, I tried that; it didn't help. – Josh Yeager May 16 '11 at 19:30
up vote 0 down vote accepted

I found the problem. This only happens on my work laptop. Someone at work set up a DNS alias for "fileserver" that points to Amazon AWS. My laptop is caching that address and trying to use it at home.

I worked around the problem by hard-coding the correct IP address in my hosts file.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .