Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Ubuntu guest installed on Virtualbox 4.0.4 running on Windows 7 Home Premium. I have two firewall rules for Vbox which allow any, any inbound for both TCP and UDP and those rules have edge traversal enabled. I have host ports 9080 and 9022 forwarded to 80 and 22 on the guest. The Win7 box is on an Ethernet connection

After some testing, I have a netbook with a Wifi connection and Ubuntu netbook remix which cannot make an ssh connection to the Ubuntu guest.

But, the same netbook can telnet to port 9080 on the Win7 machine's address and successfully connect to a web server running on port 80 of the Ubuntu guest.

In order to check this out, I ran initctl stop ssh on the Ubuntu guest, verified thagt port 22 had no listeners, and ran ssh with /usr/sbin/sshd -d -e. This shows various bits of debug info from the console. Then I ran Putty on the win7 machine to connect to port 9022 on it's own IP address (that it got from DHCP) and made a successful connection to the guest Ubuntu.

The variable that I don't know much about is the landlord's cable router setup, but I can't figure out why that would block packets to 9022 but not packets to 9080.

Where would you look next?

share|improve this question
    
In the end, I bought my own wireless router so that I have control over the connection path and can configure the router's firewall to match my needs. –  Michael Dillon Jun 21 '11 at 3:10
add comment

1 Answer

Try running your ssh client with debugging turned on. I believe this is the -vvv option. man ssh for details.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.