Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Recently Firefox is not starting in my home laptop. I start it in various ways (click the icon, start menu, start menu Run, command line, windows explorer) but nothing happens visibly. I monitored with task manager, but firefox.exe never even shows up as a process. I have set task manager refresh frequency as high. I tried to run in firefox in safe mode but nothing. From command line if I run firefox.exe -h, the task manager shows the process for a second or two and gone. But just firefox.exe doesn't show this.

I tried reinstalling, uninstall and reinstall, reboot, but no use. This happens only from my user account. If I switch user to another couple of accounts (admin and non-admin), the browser starts without problem. I searched the internet but most of the problems mentioned about firefox not appearing but atleast showing up in the task manager. I tried renaming the profile directory (in case something wrong with the profiles) but no use.

One thing noticed with profile directory, when I tried renaming the directory in windows explorer (F2, change name, Enter), the name went back to original name (without any error message or warning). I couldn't change any directory in AppData\Roaming in explorer. I had to do that from command line. Could this be an issue?

Any help is appreciated.

Thanks, Takeiteasy.

share|improve this question

2 Answers 2

It sounds like on of your add-ons might be causing problems.

I'd suggest deleting your profile folder, I think in vista it's in your users folder under a folder called appdata\mozilla\firefox\profiles with a fairly horrible name. Once this is gone just try launching firefox as normal.

If it won't delete from your account try switching to one of the admin accounts then deleting it.

share|improve this answer
    
I have tried that. I don't think it goes even to the add-on stage. Even safe mode doesn't work. In fact, when I remove the profiles directory and rerun firefox (either new installation or old), it doesn't even create the profile directory again. I wish if there is a way to see if firefox spits any error message before it exits (I don't think it crashes, windows would have caught it then). –  Takeiteasy Aug 24 '09 at 17:02
    
Um, do you know if the accounts that work were set up before or after the one that doesn't. I'm just wondering if something changed in the default profile after the working ones were set up and before the broken one. –  Col Aug 25 '09 at 11:33

I had this problem once. The best solution I can offer is to download Revo Uninstaller and use it to uninstall Firefox. When it asks if you would like to remove all personal settings, you must say "yes" so it will uninstall the profile for that user account (basically reset everything to like the first time you installed it). Revo will also allow you to have it scan the registry and the hard disk for any remaining files. Check that option as well. Once Firefox is uninstalled, empty the recycle bin if there are any remnants there and reboot. Once you've rebooted, reinstall Firefox. That's what I did, and it worked for me. Hope it helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.