Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I uninstalled Windows Media Player from my Windows 7 64-bit install. Now the "Play all" option in explorer does nothing (earlier it used to queue all files in Windows Media Player).

The Play All Button in explorer

Is there any way to make the play all option use another media player (like VLC)? Setting VLC as the default music player doesn't work.

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Right click on any audio file (eg: .mp3) and click on properties. Under the general tab click the 'Change' button next to 'Opens with:'. Here select a program that you would like to open when using the 'Play All' button (eg: VLC). Accepts these settings by clicking a series of OK's and Apply's. If you have various audio files types (.wav, .wma, etc:), you may need to follow the above steps on these files as well.

But remember, you will need to do this only once per file type.

share|improve this answer
    
I had set VLC to default before, but I did it again once to be sure. Now I find very strange behavior. For example, I have a folder A with 12 mp3 files, and folder B with 5 files. Play All works on B, but not on A. –  Arvind Raja Yadav May 15 '11 at 16:21

Indeed, as others said, this is a problem related with setting a default player for your media. It works with the Open With menu but there's also another solution. It is more elegant and it allows you to change much fast the default program for a set of extensions. You can find it here:

How to Associate a File Type or Protocol to a Program

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.