Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a QNAP NAS that offers a few SMB shares. As I'm in a trusted environment, my shares are accessible as guest rather than with a combination of username and password.

Problem

Now, when I click the name of the device in Finder's sidebar, I get the black "Connection failed" bar, with the option "Connect as...". When I click that, I receive:

enter image description here

I can however press  + K and enter the server's name manually, which gets me to this window:

enter image description here

Here, I have to select "guest". Now, I can select one of the shares to connect to, and I'm finally connected to the server. If I select it in the sidebar, I get a list of all shares available, because I'm connected as "guest", obviously:

enter image description here

What I need

Well, as soon as I unmount all shares, I have to go through the same procedure of manually logging in as "guest" again, which I find quite annoying.

Is there any way I could get Finder (or the underlying SMB client) to know which credentials to use?

Or should I look for the solution rather on the server side? (I know that other SMB shares seem to work fine in my network)

Diagnostics

The only thing I can get out of Console.app is:

5/15/11 7:36:40 PM  /System/Library/CoreServices/Finder.app/Contents/MacOS/Finder[200]  SharePointBrowser::handleOpenCallBack returned 64

This message occurs when I click the name of the SMB server in the Finder sidebar.

Here's the output of `smbclient -L meredith -U guest -d=2

charon:~ werner$ smbclient -L meredith -U guest -d=2
added interface ip=192.168.100.11 bcast=192.168.100.255 nmask=255.255.255.0
tdb(unnamed): tdb_open_ex: could not open file /private/var/samba/gencache.tdb: Permission denied
Got a positive name query response from 192.168.100.100 ( 192.168.100.100 )
Password: 
Domain=[MEREDITH] OS=[Unix] Server=[Samba 3.5.2]

    Sharename       Type      Comment
    ---------       ----      -------
    music           Disk      
    movies          Disk      
    photos          Disk      
    software        Disk      
    archive         Disk      
    backups         Disk      
    IPC$            IPC       IPC Service (NAS Server)
Got a positive name query response from 192.168.100.100 ( 192.168.100.100 )
Domain=[MEREDITH] OS=[Unix] Server=[Samba 3.5.2]

    Server               Comment
    ---------            -------

    Workgroup            Master
    ---------            -------
    WORKGROUP            MEREDITH

Also, things I've tried:

  • There is no relevant entry in the Keychain (but why would it, I'm only connecting as guest)
  • Connecting with user name "Guest" and empty password logs me in but still after ejecting the last share, I get the same "Connection failed" error as before. The appropriate entry is made in the Keychain but obviously has no effect.

Keychain

share|improve this question
add comment

4 Answers 4

Here's an article from Apple that should fix this.

share|improve this answer
    
Nope, the article is for OS X 10.3 and dates from October 2008. Also, I can't store a username/password when I'm connecting as guest. –  slhck May 19 '11 at 20:59
    
Check the Keychain Access app (Applications > Utilities > Keychain Access). It'll be in there somewhere. –  Smurf64 May 19 '11 at 21:00
    
No, unfortunately there is no entry for the host. I've already tried looking there. As said before, the Keychain won't store entries for guests. –  slhck May 19 '11 at 21:03
    
Try typing "Guest" with a blank password and check the Remember password box. –  Smurf64 May 19 '11 at 21:08
    
That was a good idea, but still doesn't work. –  slhck May 19 '11 at 21:12
show 2 more comments

Create a file called ~/Library/Preferences/nsmb.conf and add to it:

[default]
minauth=none

Disconnect from your server, reconnect and try again. This worked for me (I had the same problem).

Found it at http://ubuntuforums.org/archive/index.php/t-917156.html

share|improve this answer
add comment

In Mac OS X 10.7.3, I used the following string in Finder's "Connect To Server..." (Command-K) for a similar server in my office:

smb://Guest:@serverAddress/volume

You need both the ':' and "@". I believe it works out as UserName:Password@address .

After the volume appeared, I tried to put it in my shortcut bar, but it wouldn't stay.

I made an alias, and tested it after disconnecting. It worked fine. No window appeared to choose "Guest".

share|improve this answer
add comment

This is probably what is happening to you: Finder will try to connect to your share using AFP instead of SMB, if unconnected and both daemons are running on the server and AFP is being advertised via Zeroconf. Not advertising AFP using Zeroconf (avahi/whatever) should fix this. Time Machine should still work.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.