Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an ASUS N53JQ with Windows 7 x64.

My problem started when I used the recovery DVDs from my laptop. Put it in, run the set-up and went to 95%, after that it went to 0% and then to 5%. I got an error code 1029 and could not finish installation. Tried that couple of times and same thing happens every time.

I formatted and deleted and created and formatted and deleted the partition where Windows was on. Tried other Windows 7 installation CDs. 3 in total. Nothing worked. I get a BOOTMGR error when I start the computer, I can't enter F9 recovery partition and F8.

In my BIOS everything is ok. So I tried the repair options from the Windows 7 CDs. Didn't work. I tried:

  • Repair your computer
  • System repair. Shows no errors.

In the command screen I tried:

bootrec /rebuildbcd
bootrec.exe /rebuildbcd
bcdedit /export C:\BCD_Backup
ren c:\boot\bcd bcd.old
bootrec /rebuildbcd
bootrec.exe /fixmbr
bootrec.exe /fixboot

Nothing worked.

I restarted with CD again, and hit shift + F10 so the command prompt would show up and went to *diskpart > list disk > select disk number > list partition > select partition number > active*, so that partition would become active.

  • Partition 1 like 20GB (recovery partition) Primary
  • Partition 0 like 160 GB (don't know what it is) ?
  • Partition 2 Like 400GB (looks like partition 3, i only have 500 GB total so it has to be the same as partition 3?) Primary
  • Partition 3 Like 400GB Logical

The results were:

  • Partition 1 could be active
  • Partition 2 could be active
  • Partition 0 and 3 not.

I read that if a partition is active it will start up first. Did not work for me.

Can someone help me with how to get into F9 Hidden recovery partition while starting up and recovery this machine?

I read somewhere that there were more people with same problem, they had the hidden recovery partition but could not enter it. Saw that some could enter by making that partition active etc. But that didn't work for me. Something about bootloader etc.

I don't want to send it for repair to ASUS because last time I send my last laptop, they shipped it back with a broken frame and defect on my CD player. They say to me they didn't do it, well, I didn't do it either!

Oh and by the way, I can't use an XP CD because I get a BSoD when I use it. Tried 5 different XP CDs, 3 Windows 7 CDs, 1 Vista CD and the Recovery DVDs I made with AI recovery from ASUS.

share|improve this question

migrated from May 15 '11 at 19:30

This question came from our site for professional and enthusiast programmers.

Stack Overflow is for question related to programming. – Ash Burlaczenko May 15 '11 at 18:58
But there might be awesome brains out there who program but also know this? – F4LLCON May 15 '11 at 19:13
You should answer your question yourself, using the "answer your question" button. – slhck Oct 26 '11 at 13:33
@slhck Hello, Thank you for cleaning up my question. But Why did you remove the 'problem solved'? The rest looks nice – F4LLCON Jan 26 '12 at 10:44
@F4LLCON Because that's not how it works here. You can't put the answer into the question :) This is not a forum. You need to answer your own question and accept that answer to mark it as "solved". – slhck Jan 26 '12 at 12:15
up vote 0 down vote accepted

When the installation disc fails, it's usually:

  • Bad install disc - probably not in this case, since different media fails, too.
  • Bad hard drive - sometimes this shows when install fails at the same point every time. Easy to verify with a bootable drive scan CD or USB stick
  • Bad RAM - can be tough to remove a stick in a laptop to test, but again, bootable media with a RAM checker will answer this for you.

There are lots of threads here to help with testing those bits. should get you started.

share|improve this answer
Hello, I managed to install windows at last, but now my F9 recovery partition still not works. I can see it under D:\RECOVERY. I have contacted the shop and they told me to send it, and it will take 2 - 4 weeks ..... I will also call ASUS now for more information and if i can fix it myself or not. Thank you – F4LLCON May 16 '11 at 9:30
You can't mess with your partitions and still expect the Recovery partition to just magically work – Canadian Luke Oct 12 '11 at 4:54
@Luke , seeing this post after a while, your comment is irrelevant. As I mentioned, the original ASUS DVD's that I burned after starting my laptop for the first time erased my entire disc and did not even install windows. Nothing to do with 'messing' up the partition. – F4LLCON Apr 27 '12 at 16:22

I just encountered this 'error code 1029' problem on an Asus X52F yesterday, when I replaced the 320GB drive with a 750GB one.

The short story is that the 3 recovery DVDs created a ~20GB partition that was aligned to sector 64 instead of sector 63! Because the 320GB drive was still functioning, I could 'dd' the hidden partition and save a copy. I was then able to take that saved copy and 'dd' it back to the 750GB drive, but at an offset of 63 instead of 64 (i.e. I had to re-partition the disk that was created by the recovery DVDs, and effectively move that hidden partition by one sector!). Once that was done, all I had to do was convince it to boot from the hidden partition (I used Ubuntu, as this was a dual-boot machine) and the re-install of the factory OS worked.

I'm posting this in the hopes that others read it, and it saves someone the hours it took me to find this solution.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.