Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On every single linux distribution I have used the last 10 years there has been the following inconvenience: You run a program in the terminal using bash. After the program is stopped or interrupted, whatever you type sometimes appears invisible. You can then enter the command "reset" and the screen is cleared and the cursor is visible again.

Because of this bug, I always changed shell to zsh whenever I login to a new terminal for the first time. In zsh the invisible text bug never happens. Since the bug now has been there for over 10 years now I've begun to suspect that it is a feature of bash. So, can anyone tell me what it's good for?

Also, where is the bash home page/bug tracker actually located. Bash.org seems to be about "IT bashing", and so does the #bash irc channel. Why do most linux distributions include a shell which is so hard to give feedback to, when several alternatives is at least as good?

share|improve this question

migrated from stackoverflow.com May 15 '11 at 20:24

This question came from our site for professional and enthusiast programmers.

1  
So... which part of your question is programming-related again? –  Ignacio Vazquez-Abrams May 15 '11 at 19:01
2  
Please direct me to the correct place to ask. The irony is that a google search on "bash shell bug tracker" currently leads to this page. –  Jonas May 15 '11 at 19:21
    
Man, when you make a question: fidlitidly gigly midly, and after will search google for fidlitidly will get a link to SO. What's magical? –  jomo666 May 15 '11 at 19:27
    
That's what happen when you cat binary files... –  Yab May 16 '11 at 6:50

1 Answer 1

That's only mean than in zsh you cannot do something like:

stty -echo     #turn off echoing what you type
stty echo      #turn on echoing
reset          #reset terminal to the default state

In bash, the above command works as expected - turn off echoing of command. Just tried in zsh - does not work. Who has a bug? ;)

Turning off echoing is possible achieve with ESC sequences, so if your program randomly send binary sequences to terminal, {or when you CTRL-\ some screen oriented program),it behaves sometimes like stty -echo and you must reset it. It is not a bug - simply it is how terminals (and terminal emulators) works.

What is strange, why in zsh stty -echo does not works.

share|improve this answer
1  
In zsh, you can ttyctl -f to disallow changes to the terminal modes, and ttyctl -u to allow them. –  jilles May 15 '11 at 20:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.