Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I know that the @ in

-rwxrwxrwx@ 1 me  staff     0 16 Mai 10:55 myLog.txt

means, that there is some extended metadata attached.

Fine. Doesn't interest me.

I need to know how to remove it ?

I get this again and again while in developing stage of some php scripts. And again and again my logfiles get blocked by the @ and my scripts can't write into the log-files anymore. My only solution so far: remove the file and recreate it and rechmod the permissions of the file, which of course sucks.

And maybe you can tell me what is causing it ? It seems completly random. Can I deactivate this blocking @

Edit and Solution:

Thanks to the comments I have found out now that the following command removes the "@"

xattr -d com.macromates.caret filename

And the next command prevents Textmate from adding it again (close Textmate before running the command).

defaults write com.macromates.textmate OakDocumentDisableFSMetaData 1

Source and more infos here

share|improve this question
1  
TextMate uses extended attributes (resource fork) for persisting the caret position. Are you using TextMate? Check its preferences, you can disable this feature. –  Daniel Beck May 16 '11 at 9:22
    
Wow, I use it indeed. So TextMate does this huh, strange that it's so random, is it buggy ? –  Allisone May 16 '11 at 9:41
    
Can't find the place in settings where I could deactivate such thing –  Allisone May 16 '11 at 9:43
    
"Blocked"? That sounds suspect... –  Ignacio Vazquez-Abrams May 16 '11 at 9:46
    
@Allisone Glad that helped. Hope you don't mind that I re-posted as answer, I'd appreciate an accept if that's what you were actually looking for. –  Daniel Beck May 16 '11 at 9:56

1 Answer 1

up vote 5 down vote accepted

Extended attributes are most likely added by your text editor. TextMate uses them to store e.g. the caret position. Disable that feature of to get rid of the unused extended attributes altogether.

You can delete extended attributes using

xattr

and list them using

ls -l@
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.